summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmir Zarrinkafsh2021-09-14 18:07:09 +1000
committerAmir Zarrinkafsh2021-09-14 18:07:09 +1000
commit312ecaa05db4498bdbc61a404367f7365128b09a (patch)
tree81bb9a368e9956a969b4376ac3ddc303c1332119
parent3bc50ad4b66f0f31c2a16f883cc6a70f278a44c5 (diff)
downloadaur-312ecaa05db4498bdbc61a404367f7365128b09a.tar.gz
Update to v4.30.5
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18322b04a96e..865f72bd2f2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = authelia
pkgdesc = The Cloud ready multi-factor authentication portal for your Apps.
- pkgver = 4.30.4
- pkgrel = 2
+ pkgver = 4.30.5
+ pkgrel = 1
url = https://github.com/authelia/authelia
arch = x86_64
arch = aarch64
arch = armv7h
license = Apache-2.0
+ makedepends = curl
makedepends = gcc
- makedepends = git
makedepends = go
+ makedepends = jq
makedepends = nodejs
makedepends = yarn
conflicts = authelia-bin
conflicts = authelia-git
backup = etc/authelia/configuration.yml
- source = authelia-4.30.4.tar.gz::https://github.com/authelia/authelia/archive/v4.30.4.tar.gz
- sha256sums = 0be88888ae1fc1a488417cbda09c0e01adee98002b13249992c828a5e4612dd1
+ source = authelia-4.30.5.tar.gz::https://github.com/authelia/authelia/archive/v4.30.5.tar.gz
+ sha256sums = b058acd73dd9433dabb3ced59380f29ebe4450a1569824781a45ca04ae59b0ed
pkgname = authelia
diff --git a/PKGBUILD b/PKGBUILD
index 111e45008b20..dc9ac5c90dc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Amir Zarrinkafsh <nightah at me dot com>
pkgname=authelia
-pkgver=4.30.4
-pkgrel=2
+pkgver=4.30.5
+pkgrel=1
pkgdesc="The Cloud ready multi-factor authentication portal for your Apps."
arch=('x86_64' 'aarch64' 'armv7h')
url="https://github.com/authelia/authelia"
@@ -22,10 +22,10 @@ backup=('etc/authelia/configuration.yml')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('0be88888ae1fc1a488417cbda09c0e01adee98002b13249992c828a5e4612dd1')
+sha256sums=('b058acd73dd9433dabb3ced59380f29ebe4450a1569824781a45ca04ae59b0ed')
build() {
- export GOPATH="$srcdir/gopath" PATH="$PATH:$srcdir/gopath/bin" _pkgver="v${pkgver}"
+pkgver=4.30.5
cd "$srcdir/$pkgname-$pkgver/web"
COMMIT=$(curl -s https://api.github.com/repos/authelia/authelia/tags | jq -r '.[] | select(.name==env._pkgver) | .commit.sha')