summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmir Zarrinkafsh2020-01-24 14:29:08 +1100
committerAmir Zarrinkafsh2020-01-24 14:29:08 +1100
commit93e481864484e49270d5dbc9b4910862157af6c2 (patch)
tree48f37b79f997e9105077a8aa313cd7b217d2c307
parent928d3e0e9cf1f53069d47ae805200b98d018aa2a (diff)
downloadaur-93e481864484e49270d5dbc9b4910862157af6c2.tar.gz
Fix conflicts and remove unnecessary provides/makedepends
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c78b4f1de53..ba96899699cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = authelia
pkgdesc = The Cloud ready multi-factor authentication portal for your Apps.
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/authelia/authelia
arch = x86_64
arch = aarch64
arch = armv7h
license = Apache-2.0
- makedepends = curl
makedepends = gcc
makedepends = git
makedepends = go
makedepends = nodejs
makedepends = yarn
- provides = authelia
conflicts = authelia-bin
+ conflicts = authelia-git
backup = etc/authelia/configuration.yml
source = authelia-4.2.0.tar.gz::https://github.com/authelia/authelia/archive/v4.2.0.tar.gz
source = authelia.service
diff --git a/PKGBUILD b/PKGBUILD
index 9c3d46dc4010..ae25d0c78901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Amir Zarrinkafsh <nightah at me dot com>
pkgname=authelia
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Cloud ready multi-factor authentication portal for your Apps."
arch=('x86_64' 'aarch64' 'armv7h')
url="https://github.com/authelia/authelia"
license=('Apache-2.0')
makedepends=(
- 'curl'
'gcc'
'git'
'go'
'nodejs'
'yarn'
)
-provides=('authelia')
-conflicts=('authelia-bin')
+conflicts=(
+ 'authelia-bin'
+ 'authelia-git'
+)
backup=('etc/authelia/configuration.yml')
source=(
@@ -31,7 +32,7 @@ sha256sums=(
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i "s/__BUILD_TAG__/v${pkgver}/" cmd/authelia/constants.go
- sed -i "s/__BUILD_COMMIT__/$(curl https://api.github.com/repos/${pkgname}/${pkgname}/git/refs/tags/v${pkgver} | awk -F '["]' '/"sha"/{print $4}')/" cmd/authelia/constants.go
+ sed -i "s/__BUILD_COMMIT__/$(git rev-parse --verify v${pkgver})/" cmd/authelia/constants.go
go build -ldflags '-w' -trimpath -o authelia cmd/authelia/*.go
cd web
yarn install --frozen-lockfile