summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-05 11:14:50 +0800
committerzxp198210052023-07-05 11:14:50 +0800
commit05e6f2ab9605ff9a70de389b1a065d04ea2fb4b6 (patch)
treed5ab8b789604f474a7bb37b5e7d75d4f3fc94465
parent262640f8f35f9953c0f89efc5c94140ca93d765e (diff)
downloadaur-05e6f2ab9605ff9a70de389b1a065d04ea2fb4b6.tar.gz
update to 1.9.9
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--authpass.desktop10
3 files changed, 31 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bec9df495aba..a37debbae3dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = authpass-bin
- pkgdesc = Keepass compatible password manager based on Flutter
- pkgver = 1.9.7
+ pkgdesc = Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.
+ pkgver = 1.9.9
pkgrel = 1
- url = https://github.com/authpass/authpass
+ url = https://authpass.app/
arch = x86_64
license = GPL3
depends = gtk3
depends = libsecret
depends = libkeybinder3
+ depends = gcc-libs
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = libepoxy
+ depends = at-spi2-core
+ depends = glibc
+ depends = pango
+ depends = glib2
provides = authpass
conflicts = authpass
- source = authpass-bin-1.9.7.tar.gz::https://github.com/authpass/authpass/releases/download/v1.9.7/authpass-linux-1.9.7_1940.tar.gz
- source = authpass-1.9.7.svg::https://github.com/authpass/authpass/raw/v1.9.7/_docs/authpass-logo.svg
- source = authpass.desktop
- sha256sums = c39456ab421d2c279555ec3bd81de3ac41cb720c49eff1cee82979fd50b30409
- sha256sums = 1bfe9685c9399976a872bfcafbe19c16b26063530cdc9184570270d52fe7851b
- sha256sums = 8260ede1bb38264aa92227dee1b3edd0d66b1f963872d4254549c08c7ca409dd
+ source = authpass-1.9.9.deb::https://data.authpass.app/data/artifacts/authpass-linux-1.9.9_1950.deb
+ sha256sums = a80ac234e19f35f6db4858579c963054f7b7ded64f7112478c178940e0d311ba
pkgname = authpass-bin
diff --git a/PKGBUILD b/PKGBUILD
index 846ec3417c51..43357b90f336 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-
pkgname=authpass-bin
-_pkgname="${pkgname%-bin}"
-pkgver=1.9.7
-_rev=1940
+pkgver=1.9.9
+_rev=1950
pkgrel=1
-pkgdesc='Keepass compatible password manager based on Flutter'
+pkgdesc='Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.'
arch=('x86_64')
-url='https://github.com/authpass/authpass'
+url="https://authpass.app/"
+_githuburl="https://github.com/authpass/authpass"
+_downurl="https://data.authpass.app/data/artifacts"
license=('GPL3')
-depends=('gtk3' 'libsecret' 'libkeybinder3')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=(
- "$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/$_pkgname-linux-${pkgver}_${_rev}.tar.gz"
- "$_pkgname-$pkgver.svg::$url/raw/v$pkgver/_docs/authpass-logo.svg"
- "${_pkgname}.desktop")
-sha256sums=('c39456ab421d2c279555ec3bd81de3ac41cb720c49eff1cee82979fd50b30409'
- '1bfe9685c9399976a872bfcafbe19c16b26063530cdc9184570270d52fe7851b'
- '8260ede1bb38264aa92227dee1b3edd0d66b1f963872d4254549c08c7ca409dd')
-
+depends=('gtk3' 'libsecret' 'libkeybinder3' 'gcc-libs' 'cairo' 'gdk-pixbuf2' 'libepoxy' 'at-spi2-core' 'glibc' 'pango' 'glib2')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.deb::${_downurl}/${pkgname%-bin}-linux-${pkgver}_${_rev}.deb")
+sha256sums=('a80ac234e19f35f6db4858579c963054f7b7ded64f7112478c178940e0d311ba')
package() {
- install -Dm644 "$_pkgname.desktop" -t "$pkgdir/usr/share/applications"
- install -Dm644 "$_pkgname-$pkgver.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
- install -d "$pkgdir/opt/$_pkgname/"
- install -d "$pkgdir/usr/bin/"
- cp -a --no-preserve=ownership authpass/* "$pkgdir/opt/$_pkgname/"
- ln -s "/opt/$_pkgname/$_pkgname" -t "$pkgdir/usr/bin/"
- chown -R root:root "$pkgdir/"
-}
-
-# vim: ts=2 sw=2 et:
+ bsdtar -xf "${srcdir}/data.tar.zst" -C "${pkgdir}"
+ install -Dm0644 "${pkgdir}/opt/${pkgname%-bin}/icon.svg" "${pkgdir}/usr/share/hicolor/scalable/apps/${pkgname%-bin}"
+ sed "s|/usr/bin/${pkgname%-bin}|/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|/opt/${pkgname%-bin}/icon.svg|${pkgname%-bin}|g;s|Network|Network;Utility|g" \
+ -i "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+} \ No newline at end of file
diff --git a/authpass.desktop b/authpass.desktop
deleted file mode 100644
index 208869b258dd..000000000000
--- a/authpass.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=AuthPass
-Comment=Keepass compatible password manager based on Flutter
-Exec=authpass
-Icon=authpass
-Terminal=false
-StartupNotify=false
-Categories=Utility;