summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-20 13:17:44 +0800
committerzxp198210052023-10-20 13:17:44 +0800
commit1eb96723abdf82bfaf93e7369fa4ea0df9ed1f8a (patch)
treeccc36002a3949ab8cbbcc5e3f956cadeb1ab3700
parentc3bf831059be0f77448ae5f4e766dd6e8cbe94e3 (diff)
downloadaur-1eb96723abdf82bfaf93e7369fa4ea0df9ed1f8a.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1be568d7472e..d095591efe45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = authpass-bin
pkgdesc = Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.
- pkgver = 1.9.9_1977
- pkgrel = 1
+ pkgver = 1.9.9
+ pkgrel = 2
url = https://authpass.app/
arch = x86_64
license = GPL3
@@ -18,9 +18,9 @@ pkgbase = authpass-bin
depends = glib2
depends = fontconfig
depends = harfbuzz
- provides = authpass=1.9.9_1977
+ provides = authpass=1.9.9
conflicts = authpass
- source = authpass-1.9.9_1977.deb::https://data.authpass.app/data/artifacts/authpass-linux-1.9.9_1977.deb
+ source = authpass-1.9.9.deb::https://github.com/authpass/authpass/releases/download/v1.9.9/authpass-linux-1.9.9_1977.deb
sha256sums = 91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102
pkgname = authpass-bin
diff --git a/PKGBUILD b/PKGBUILD
index c59c41d19c16..956060d90ce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,19 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=authpass-bin
-pkgver=1.9.9_1977
-pkgrel=1
+pkgver=1.9.9
+pkgrel=2
pkgdesc='Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.'
arch=('x86_64')
url="https://authpass.app/"
_githuburl="https://github.com/authpass/authpass"
-_downurl="https://data.authpass.app/data/artifacts"
license=('GPL3')
depends=('gtk3' 'libsecret' 'libkeybinder3' 'gcc-libs' 'cairo' 'gdk-pixbuf2' 'libepoxy' 'at-spi2-core' 'glibc' 'pango' 'glib2' 'fontconfig' 'harfbuzz')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.deb::${_downurl}/${pkgname%-bin}-linux-${pkgver}.deb")
+source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${pkgver}_1977.deb")
sha256sums=('91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.zst"
sed "s|/opt/${pkgname%-bin}/icon.svg|${pkgname%-bin}|g;s|Network|Network;Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"