summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-17 12:17:51 +0800
committerzxp198210052024-01-17 12:17:51 +0800
commit87ec6e7e8b3534a1589c34df31848e1b2dbbbb75 (patch)
treed12a2c007205213f7f64249d98a1d742a0c99a0a
parentac4ff4479876c48144d591f9a6932ee7f828bb37 (diff)
downloadaur-87ec6e7e8b3534a1589c34df31848e1b2dbbbb75.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--authpass.sh8
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68c5c499e3e4..97d2039fa43e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = authpass-bin
pkgdesc = Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.
pkgver = 1.9.9
- pkgrel = 3
+ pkgrel = 4
url = https://authpass.app/
arch = x86_64
license = GPL3
@@ -18,6 +18,8 @@ pkgbase = authpass-bin
provides = authpass=1.9.9
conflicts = authpass
source = authpass-1.9.9.deb::https://github.com/authpass/authpass/releases/download/v1.9.9/authpass-linux-1.9.9_1977.deb
+ source = authpass.sh
sha256sums = 91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102
+ sha256sums = a48e111ef6e6a93e693545d524fdd46068aa4bc5d8508f2298e274cb1e342a1a
pkgname = authpass-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2f904d504630..1960d9303d46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=authpass-bin
pkgver=1.9.9
-pkgrel=3
+pkgrel=4
pkgdesc='Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.'
arch=('x86_64')
url="https://authpass.app/"
@@ -25,17 +25,21 @@ depends=(
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${pkgver}_1977.deb"
+ "${pkgname%-bin}.sh"
)
-sha256sums=('91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102')
+sha256sums=('91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102'
+ 'a48e111ef6e6a93e693545d524fdd46068aa4bc5d8508f2298e274cb1e342a1a')
build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${pkgname%-bin}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.zst"
sed "s|/opt/${pkgname%-bin}/icon.svg|${pkgname%-bin}|g;s|Network|Network;Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
- cp -r "${srcdir}/opt/${pkgname%-bin}" "${pkgdir}/opt"
- ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ cp -r "${srcdir}/opt" "${pkgdir}"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm0644 "${srcdir}/opt/${pkgname%-bin}/icon.svg" "${pkgdir}/usr/share/hicolor/scalable/apps/${pkgname%-bin}"
} \ No newline at end of file
diff --git a/authpass.sh b/authpass.sh
new file mode 100644
index 000000000000..dd5c3a0d256f
--- /dev/null
+++ b/authpass.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+set -e
+_APPDIR=/opt/@appname@
+_RUNNAME="${_APPDIR}/@runname@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+cd "${_APPDIR}"
+exec "${_RUNNAME}" "$@" | exit \ No newline at end of file