summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-08 18:05:28 +0800
committerzxp198210052023-12-08 18:05:28 +0800
commitac4ff4479876c48144d591f9a6932ee7f828bb37 (patch)
tree449e7bff1dae723c69a2bded6aa5f5f39a00ee23
parent1eb96723abdf82bfaf93e7369fa4ea0df9ed1f8a (diff)
downloadaur-ac4ff4479876c48144d591f9a6932ee7f828bb37.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d095591efe45..68c5c499e3e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = authpass-bin
pkgdesc = Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.
pkgver = 1.9.9
- pkgrel = 2
+ pkgrel = 3
url = https://authpass.app/
arch = x86_64
license = GPL3
depends = gtk3
depends = libsecret
depends = libkeybinder3
- depends = gcc-libs
depends = cairo
depends = gdk-pixbuf2
depends = libepoxy
depends = at-spi2-core
- depends = glibc
depends = pango
- depends = glib2
depends = fontconfig
depends = harfbuzz
provides = authpass=1.9.9
diff --git a/PKGBUILD b/PKGBUILD
index 956060d90ce0..2f904d504630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,29 @@
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=authpass-bin
pkgver=1.9.9
-pkgrel=2
+pkgrel=3
pkgdesc='Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.'
arch=('x86_64')
url="https://authpass.app/"
-_githuburl="https://github.com/authpass/authpass"
+_ghurl="https://github.com/authpass/authpass"
license=('GPL3')
-depends=('gtk3' 'libsecret' 'libkeybinder3' 'gcc-libs' 'cairo' 'gdk-pixbuf2' 'libepoxy' 'at-spi2-core' 'glibc' 'pango' 'glib2' 'fontconfig' 'harfbuzz')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${pkgver}_1977.deb")
+depends=(
+ 'gtk3'
+ 'libsecret'
+ 'libkeybinder3'
+ 'cairo'
+ 'gdk-pixbuf2'
+ 'libepoxy'
+ 'at-spi2-core'
+ 'pango'
+ 'fontconfig'
+ 'harfbuzz'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${pkgver}_1977.deb"
+)
sha256sums=('91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102')
build() {
bsdtar -xf "${srcdir}/data.tar.zst"
@@ -20,7 +33,7 @@ build() {
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 -d "${pkgdir}/opt" "${pkgdir}/usr/bin"
+ install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
cp -r "${srcdir}/opt/${pkgname%-bin}" "${pkgdir}/opt"
ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"