summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2019-03-20 12:57:11 +0100
committerfelics2019-03-20 12:57:11 +0100
commit211f457a2a83a6463d98b110b52c18bc1f169002 (patch)
treeb72412d835e72abd1bb151224fc5dd38ed1d45c9
parent35f76088e13625bc27d9fb856cbab29c3df3df8a (diff)
downloadaur-211f457a2a83a6463d98b110b52c18bc1f169002.tar.gz
Made PKGBUILD a bit more verbose.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7d4ffcb95b0..307b0b44b258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = authsae-git
pkgdesc = Authsae provides secure password-based authentication for 802.11s mesh networking.
pkgver = 1.2.9_4+r420.20190225.109a2e8
pkgrel = 1
- epoch = 2
+ epoch = 3
url = https://github.com/cozybit/authsae
arch = x86
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2d51142a2fe2..519e33a39b8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname="authsae"
pkgname="${_pkgname}-git"
pkgrel=1
pkgver=1.2.9_4+r420.20190225.109a2e8
-epoch=2
+epoch=3
pkgdesc="Authsae provides secure password-based authentication for 802.11s mesh networking."
arch=('x86' 'x86_64')
url="https://github.com/cozybit/${_pkgname}"
@@ -39,6 +39,7 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
+ msg2 "Configuring with 'cmake' ..."
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
@@ -47,8 +48,10 @@ build() {
.
# FIXME: the cmake script does something very wrong and attempts to install the config file in prefix+/etc, submit patch to upstream to allow to change that
+ msg2 "Fixing a cmake script fault: Place config in '/etc/', not '/usr/etc/' ..."
sed -i 's|/usr/etc/|/etc|' cmake_install.cmake
+ msg2 "Running 'make' ..."
make
}