summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2015-06-13 18:56:12 +0200
committerBrainDamage2015-06-13 18:56:12 +0200
commit496df949d517c771345ca1befefb0b2ee5b5bce0 (patch)
treed364fcdf904924473a5281c7f9334b175deec159
downloadaur-496df949d517c771345ca1befefb0b2ee5b5bce0.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be16a68b08fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = authsae-git
+ pkgdesc = Authsae provides secure password-based authentication for 802.11s mesh networking.
+ pkgver = 20150123.8531ab1
+ pkgrel = 1
+ url = https://github.com/cozybit/authsae
+ arch = x86
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = openssl
+ provides = authsae
+ conflicts = authsae
+ source = git+https://github.com/cozybit/authsae.git
+ md5sums = SKIP
+
+pkgname = authsae-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d86b388a4fc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: BrainDamage
+pkgname="authsae-git"
+pkgrel=1
+pkgver="20150123.8531ab1"
+pkgdesc="Authsae provides secure password-based authentication for 802.11s mesh networking."
+arch=('x86' 'x86_64')
+url="https://github.com/cozybit/authsae"
+license=("BSD")
+depends=("openssl")
+makedepends=("git")
+provides=("authsae")
+conflicts=("authsae")
+optdepends=()
+md5sums=("SKIP")
+source=("git+https://github.com/cozybit/authsae.git")
+
+pkgver() {
+ cd "$srcdir/authsae"
+ #uuuugly code to use date + current git hash in lieu of absent release tag
+ echo "$(date +%Y%m%d).$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/authsae"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ #FIXME: the cmake script does something very wrong and attempts to install the config file in prefix+/etc, submit patch to upstream to allow to change that
+ sed -i 's/\/usr\/etc/\/etc/' cmake_install.cmake
+ make
+}
+
+package() {
+ cd "$srcdir/authsae"
+ make DESTDIR=$pkgdir install
+ install -D README "$pkgdir/usr/share/authsae/README"
+} \ No newline at end of file