summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2016-04-20 21:21:51 +0200
committerBrainDamage2016-04-20 21:21:51 +0200
commitcb17aaa6f7c84d1911554b3b9f2f1c713b68505c (patch)
tree79007c67cb1d57efc4c6b091207650f29391e187
parent496df949d517c771345ca1befefb0b2ee5b5bce0 (diff)
downloadaur-cb17aaa6f7c84d1911554b3b9f2f1c713b68505c.tar.gz
explicitly mark build type as release
updated missing build dependencies and runtime dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be16a68b08fc..35987ce2beba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Apr 20 19:19:08 UTC 2016
pkgbase = authsae-git
pkgdesc = Authsae provides secure password-based authentication for 802.11s mesh networking.
- pkgver = 20150123.8531ab1
+ pkgver = 20160420.a1ebd8c
pkgrel = 1
url = https://github.com/cozybit/authsae
arch = x86
arch = x86_64
license = BSD
makedepends = git
+ makedepends = cmake
depends = openssl
+ depends = libconfig
provides = authsae
conflicts = authsae
source = git+https://github.com/cozybit/authsae.git
diff --git a/PKGBUILD b/PKGBUILD
index d86b388a4fc5..08106862f6c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: BrainDamage
pkgname="authsae-git"
pkgrel=1
-pkgver="20150123.8531ab1"
+pkgver=20160420.a1ebd8c
pkgdesc="Authsae provides secure password-based authentication for 802.11s mesh networking."
arch=('x86' 'x86_64')
url="https://github.com/cozybit/authsae"
license=("BSD")
-depends=("openssl")
-makedepends=("git")
+depends=("openssl" "libconfig")
+makedepends=("git" "cmake")
provides=("authsae")
conflicts=("authsae")
optdepends=()
@@ -22,7 +22,7 @@ pkgver() {
build() {
cd "$srcdir/authsae"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
#FIXME: the cmake script does something very wrong and attempts to install the config file in prefix+/etc, submit patch to upstream to allow to change that
sed -i 's/\/usr\/etc/\/etc/' cmake_install.cmake
make