summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-03-20 23:35:51 -0400
committerPatrick Northon2021-03-20 23:35:51 -0400
commit425423a79088514803580fe197871524afbea537 (patch)
tree99fe2e987cdae1173eea4c1ac15338da11ba1f4f
downloadaur-425423a79088514803580fe197871524afbea537.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ffb0916f172
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = authselect
+ pkgdesc = Authselect is a tool to select system authentication and identity sources from a list of supported profiles.
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/authselect/authselect
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = popt
+ depends = asciidoc
+ provides = authconfig
+ conflicts = authconfig
+ source = https://github.com/authselect/authselect/archive/refs/tags/1.2.2.tar.gz
+ sha256sums = 1b0d7b1c2a83734b4fefc06355d7a6965d5fefa62d99944cdff1e835d7b91105
+
+pkgname = authselect
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32b3db49f7d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=authselect
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Authselect is a tool to select system authentication and identity sources from a list of supported profiles."
+arch=('i686' 'x86_64')
+url="https://github.com/authselect/authselect"
+license=('GPL3')
+depends=('popt' 'asciidoc')
+provides=('authconfig')
+conflicts=('authconfig')
+makedepends=()
+source=("https://github.com/${pkgname}/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('1b0d7b1c2a83734b4fefc06355d7a6965d5fefa62d99944cdff1e835d7b91105')
+
+_srcdir="${pkgname}-${pkgver}"
+
+prepare() {
+ cd "${_srcdir}"
+ autoreconf -i
+}
+
+build() {
+ cd "${_srcdir}"
+ ./configure --prefix=/usr --localstatedir=/var --sbindir=/usr/bin --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${_srcdir}"
+ make DESTDIR="${pkgdir}" install
+ install -Dpm644 'COPYING' -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}