summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-05 10:21:12 -0700
committerMark Wagie2024-01-05 10:21:12 -0700
commit3c56c052fbb38ca38fcecd0f917a3ee714080394 (patch)
treeee904debf13d3460883e9ee949f132e626151e91
parentd13a92eeb435d9c54145a78e6e3d71dacf37ecae (diff)
downloadaur-3c56c052fbb38ca38fcecd0f917a3ee714080394.tar.gz
Use Electron 28
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--authy.sh2
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c56b4838b0af..5d132ef104c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = authy-electron
pkgdesc = Two factor authentication desktop application
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://authy.com
arch = x86_64
license = unknown
makedepends = squashfs-tools
- depends = electron25
+ depends = electron28
provides = authy
conflicts = authy
source = authy-2.4.2-22.snap::https://api.snapcraft.io/api/v1/snaps/download/H8ZpNgIoPyvmkgxOWw5MSzsXK1wRZiHn_22.snap
source = authy.sh
sha256sums = 406bde28157122272c1a192ab3e953ee50c3204260a1e5dfe3d71c89d18ae115
- sha256sums = c76a44a0b42b7b590c4b6318b0544cedb96ef76b92269a79d29f71ced5c74331
+ sha256sums = 5ec304c59d4f7770fb1bcf3465ae77b445be553b9e6be466c5e42381ccaed610
pkgname = authy-electron
diff --git a/PKGBUILD b/PKGBUILD
index 9e201648ec48..407ae87a072f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=authy-electron
pkgver=2.4.2
-pkgrel=1
-_electronversion=25
+pkgrel=2
+_electronversion=28
pkgdesc="Two factor authentication desktop application"
arch=('x86_64')
url="https://authy.com"
@@ -16,13 +16,15 @@ _snaprev='22'
source=("authy-$pkgver-${_snaprev}.snap::https://api.snapcraft.io/api/v1/snaps/download/${_snapid}_${_snaprev}.snap"
"authy.sh")
sha256sums=('406bde28157122272c1a192ab3e953ee50c3204260a1e5dfe3d71c89d18ae115'
- 'c76a44a0b42b7b590c4b6318b0544cedb96ef76b92269a79d29f71ced5c74331')
+ '5ec304c59d4f7770fb1bcf3465ae77b445be553b9e6be466c5e42381ccaed610')
prepare() {
unsquashfs -f -d "authy-$pkgver" "authy-$pkgver-${_snaprev}.snap"
cd "authy-$pkgver"
sed -i 's|${SNAP}/meta/gui/icon.png|authy|g' "meta/gui/authy.desktop"
+
+ sed -i "s|@ELECTRONVERSION@|${_electronversion}|" "$srcdir/authy.sh"
}
package() {
diff --git a/authy.sh b/authy.sh
index 71c67e153a96..4cdcdbeae566 100644
--- a/authy.sh
+++ b/authy.sh
@@ -1,4 +1,4 @@
#!/bin/sh
export ELECTRON_IS_DEV=0
-exec electron25 /usr/lib/authy/app.asar "$@"
+exec electron@ELECTRONVERSION@ /usr/lib/authy/app.asar "$@"