summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-05-31 12:20:26 -0600
committerMark Wagie2023-05-31 12:20:26 -0600
commit4132d7648f5e4297c52bdaea2570dcaac901c610 (patch)
treebb2292b5213df1520139aef88049a794df7c79bb
parent58a1adfed328c7f8a161b3e9acdafbd6db78dc1f (diff)
downloadaur-4132d7648f5e4297c52bdaea2570dcaac901c610.tar.gz
Use Electron 24
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--authy.sh2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 818b194cd5af..22d086d2851d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = authy-electron
pkgdesc = Two factor authentication desktop application
pkgver = 2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://authy.com
arch = x86_64
license = unknown
makedepends = squashfs-tools
- depends = electron22
+ depends = electron24
provides = authy
conflicts = authy
source = authy-2.3.0-19.snap::https://api.snapcraft.io/api/v1/snaps/download/H8ZpNgIoPyvmkgxOWw5MSzsXK1wRZiHn_19.snap
source = authy.sh
sha256sums = 58dfef718de47c5fc7419ee8a7221d0debd4e680d80c68ec852ed7554ef2ae3f
- sha256sums = 4f6d35fc188e37268ebadca0c23d1dda3f1d32218bf4d74e3eb387562adef34c
+ sha256sums = ac2c49b4a4119114217c5633cbb79fcf4b39dde03d643fbdd468c4355b0d4d52
pkgname = authy-electron
diff --git a/PKGBUILD b/PKGBUILD
index e4f97f91c362..b7420dd354ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=authy-electron
pkgver=2.3.0
-pkgrel=1
-_electronversion=22
+pkgrel=2
+_electronversion=24
pkgdesc="Two factor authentication desktop application"
arch=('x86_64')
url="https://authy.com"
@@ -16,7 +16,7 @@ _snaprev='19'
source=("${pkgname%-*}-$pkgver-$_snaprev.snap::https://api.snapcraft.io/api/v1/snaps/download/${_snapid}_${_snaprev}.snap"
"${pkgname%-*}.sh")
sha256sums=('58dfef718de47c5fc7419ee8a7221d0debd4e680d80c68ec852ed7554ef2ae3f'
- '4f6d35fc188e37268ebadca0c23d1dda3f1d32218bf4d74e3eb387562adef34c')
+ 'ac2c49b4a4119114217c5633cbb79fcf4b39dde03d643fbdd468c4355b0d4d52')
prepare() {
unsquashfs -f -d "$srcdir/${pkgname%-*}" "${pkgname%-*}-$pkgver-$_snaprev.snap"
diff --git a/authy.sh b/authy.sh
index 15ed52810044..1b5bc83ffb50 100644
--- a/authy.sh
+++ b/authy.sh
@@ -1,4 +1,4 @@
#!/bin/sh
export ELECTRON_IS_DEV=0
-exec electron22 /usr/lib/authy/app.asar "$@"
+exec electron24 /usr/lib/authy/app.asar "$@"