summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-08-04 11:00:45 -0600
committerMark Wagie2022-08-04 11:00:45 -0600
commit5bd607e4b4d4fbabba037fc505be9f8b44955652 (patch)
tree818c6a4838cdb6274261cb30c0ba483e547b7599
parentb7a0177c1d2d8dc029cc7690505b13c3976202e7 (diff)
downloadaur-5bd607e4b4d4fbabba037fc505be9f8b44955652.tar.gz
use Electron 20
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--authy.sh2
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6e9030ad62e..bf853fa626c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = authy-electron
pkgdesc = Two factor authentication desktop application
pkgver = 2.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://authy.com
arch = x86_64
license = unknown
makedepends = squashfs-tools
- depends = electron
+ depends = electron20
provides = authy
conflicts = authy
source = authy-2.2.1-11.snap::https://api.snapcraft.io/api/v1/snaps/download/H8ZpNgIoPyvmkgxOWw5MSzsXK1wRZiHn_11.snap
source = authy.sh
sha256sums = fdad2931755dee6129ee868dda604826fe6e3afd7343782f7e08b3d572fd6663
- sha256sums = b9eb666e25bb9083fb0f7a4072226a715ddd258fc248fa59bb80bc21651c01f0
+ sha256sums = e7df69d99022e0f04fa9e185b75bda26006b9d17c927c687384ca529f1590f06
pkgname = authy-electron
diff --git a/PKGBUILD b/PKGBUILD
index b823a413d601..91819d0633fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=authy-electron
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
+_electronversion=20
pkgdesc="Two factor authentication desktop application"
arch=('x86_64')
url="https://authy.com"
license=('unknown')
-depends=('electron')
+depends=("electron${_electronversion}")
makedepends=('squashfs-tools')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
@@ -15,7 +16,7 @@ _snaprev='11'
source=("${pkgname%-*}-$pkgver-$_snaprev.snap::https://api.snapcraft.io/api/v1/snaps/download/${_snapid}_${_snaprev}.snap"
"${pkgname%-*}.sh")
sha256sums=('fdad2931755dee6129ee868dda604826fe6e3afd7343782f7e08b3d572fd6663'
- 'b9eb666e25bb9083fb0f7a4072226a715ddd258fc248fa59bb80bc21651c01f0')
+ 'e7df69d99022e0f04fa9e185b75bda26006b9d17c927c687384ca529f1590f06')
prepare() {
unsquashfs -f -d "$srcdir/${pkgname%-*}" "${pkgname%-*}-$pkgver-$_snaprev.snap"
diff --git a/authy.sh b/authy.sh
index 2b278b87c61c..54bdb7635e3b 100644
--- a/authy.sh
+++ b/authy.sh
@@ -1,4 +1,4 @@
#!/bin/sh
export ELECTRON_IS_DEV=0
-exec electron /usr/lib/authy/app.asar "$@"
+exec electron20 /usr/lib/authy/app.asar "$@"