summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2016-03-11 00:35:51 +0100
committerfelics@felics-tablet2016-03-11 00:35:51 +0100
commit6286ca44e93276dcc7e2a67dfb816d1b75bb17d1 (patch)
treecd0aad9f6f319f79e57a81d7c4a47e6f27f4828d
parent2c5f71d19e08aae37eac902f93fbc0b93da43d49 (diff)
downloadaur-6286ca44e93276dcc7e2a67dfb816d1b75bb17d1.tar.gz
Testing how long optdepends can be.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c330aae21f1b..ef22bac13f81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Mar 10 23:34:53 UTC 2016
+# Thu Mar 10 23:35:49 UTC 2016
pkgbase = auto-07p
pkgdesc = Software for continuation and bifurcation problems in ordinary differential equations. Release 07P. Environment variables controlling build (default to 'no', see PKGBUILD): _BUILD_DOC, _WITH_PLAUT04, _PLAUT04_WITH_QT, AUTO_DEBUG, _WITH_OPENMP, _WITH_MPI.
pkgver = 0.9.1
@@ -16,6 +16,16 @@ pkgbase = auto-07p
depends = gcc-fortran
depends = gcc
depends = python2
+ optdepends = python2-matplotlib: For python interface.
+ optdepends = ipython2: For python interface.
+ optdepends = lesstif: For GUI94 and PLAUT04.
+ optdepends = openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')
+ optdepends = xterm: For PLAUT plotting interface.
+ optdepends = soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes').
+ optdepends = coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes').
+ optdepends = openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'.
+ optdepends = texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes').
+ optdepends = transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')).
options = libtool
options = staticlibs
source = http://sourceforge.net/projects/auto-07p/files/auto07p/0.9/auto07p-0.9.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9bf3a10926b3..4025025fb0e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,18 +37,18 @@ makedepends=(
'gcc'
)
optdepends=(
-# "python2-matplotlib: For python interface."
-# "ipython2: For python interface."
-# "lesstif: For GUI94 and PLAUT04."
-# "openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')"
-# "xterm: For PLAUT plotting interface."
-# "soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
+ "python2-matplotlib: For python interface."
+ "ipython2: For python interface."
+ "lesstif: For GUI94 and PLAUT04."
+ "openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')"
+ "xterm: For PLAUT plotting interface."
+ "soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
# "soqt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('soqt' can be used instead of 'soxt'. If using 'soqt', set '_PLAUT04_WITH_QT' to 'yes'.)"
-# "coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
+ "coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
# "inventor: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('inventor' can be used instead of 'coin', but 'coin' (Coin3D) is recommended (see AUTO documentation).)"
-# "openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'."
-# "texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')."
-# "transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes'))."
+ "openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'."
+ "texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')."
+ "transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes'))."
) ### Note: Some of these are optional at build time, but once a feature is build in (by './configure' automatically detecting the corresponding libraries), the packages are required to actual run AUTO, so they are _no_ optdepends for the binary package, just for the source.
license=(
'BSD'