summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2023-09-05 13:41:46 +0200
committergit user2023-09-05 13:41:46 +0200
commit3fc443f1c333faa6544eb312e84b041dbdf2ea0e (patch)
tree363d3a19c734e5393557ebed933499efdfb3898c
parent5aeb2d98a48fb341ff1bd7a34384124e9e4ec983 (diff)
downloadaur-3fc443f1c333faa6544eb312e84b041dbdf2ea0e.tar.gz
Fixed build issues, `PKGBUILD` overhaul, version bump.
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD400
2 files changed, 227 insertions, 220 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7a605a073fe..153d6255234d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,46 @@
pkgbase = auto-07p-git
- pkgdesc = Software for continuation and bifurcation problems in ordinary differential equations. Release 07P. Environment variables controlling build (default to 'no', see PKGBUILD): _BUILD_DOC, _WITH_PLAUT04, _PLAUT04_WITH_QT, AUTO_DEBUG, _WITH_OPENMP, _WITH_MPI.
+ pkgdesc = Software for continuation and bifurcation problems in ordinary differential equations. Version 07p, latest git checkout. Environment variables can control the build (see PKGBUILD).
pkgver = 0.9.3+32.r.20230504.7042e6d
- pkgrel = 1
+ pkgrel = 2
url = http://cmvl.cs.concordia.ca/auto/
+ arch = aarch64
+ arch = armv7h
+ arch = armv8h
arch = i686
arch = x86_64
license = BSD
license = LGPL2.1
license = GPL2
- makedepends = g95
- makedepends = gcc
makedepends = git
+ makedepends = perl
+ makedepends = texlive-bin
+ makedepends = transfig
depends = bash
- depends = g95
+ depends = gcc-fortran
depends = gcc
- depends = python2
- optdepends = python2-matplotlib: For python interface.
- optdepends = ipython2: For python interface.
- optdepends = lesstif: For GUI94 and PLAUT04.
- optdepends = openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')
- optdepends = xterm: For PLAUT plotting interface.
- optdepends = soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes').
- optdepends = soqt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('soqt' can be used instead of 'soxt'. If using 'soqt', set '_PLAUT04_WITH_QT' to 'yes'.)
- optdepends = coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes').
- optdepends = inventor: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('inventor' can be used instead of 'coin', but 'coin' (Coin3D) is recommended (see AUTO documentation).)
- optdepends = openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'.
- optdepends = texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes').
- optdepends = transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')).
+ depends = gcc-libs
+ depends = glibc
+ depends = libice
+ depends = libsm
+ depends = libxt
+ depends = libx11
+ depends = openmotif
+ depends = xterm
+ depends = coin
+ depends = soqt
+ depends = openmp
+ depends = openmpi
+ optdepends = ipython: For python interface.
+ optdepends = python3: For python interface.
+ optdepends = python-matplotlib: For python interface.
+ optdepends = python-numpy: For python interface.
+ optdepends = python-traitlets: For python interface.
provides = auto-07p=0.9.3+32.r.20230504.7042e6d
conflicts = auto-07p
- replaces = auto-07p<=0.9.3+32.r.20230504.7042e6d
options = libtool
options = staticlibs
source = auto-07p::git+https://github.com/auto-07p/auto-07p.git
- source = auto-07p_debian.tar.xz::https://deb.debian.org/debian/pool/main/a/auto-07p/auto-07p_0.9.2+dfsg-3.debian.tar.xz
+ source = auto-07p_0.9.2+dfsg-3.debian.tar.xz::https://deb.debian.org/debian/pool/main/a/auto-07p/auto-07p_0.9.2+dfsg-3.debian.tar.xz
source = auto-07p-session.bash
source = xpdf-dummy
source = makepkg.sh
diff --git a/PKGBUILD b/PKGBUILD
index c411cd8de7f4..53e9f66ed9af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,147 +1,178 @@
#!/bin/bash
# Above shabeng-line for automatic switch-on of syntax highlighing in some editors.
-# Maintainer: Felix Becker <felix )dot( becker (at( zih )dot) tu-dresden |dot| de>.
+# Maintainer: dreieck (https://aur.archlinux.org/account/dreieck)
### Details of the build are controlled by environment variables.
#
# The environment variables controlling the build are by now (2014-08-24):
#
-# _BUILD_DOC # Build documentation (Default: 'no')
-# _WITH_PLAUT04 # Build plaut04 (Default: 'no')
-# _PLAUT04_WITH_QT # Build plaut04 with Qt (functionality is the same) (Default: 'no')
-# _AUTO_DEBUG # Compile with debug options (Default: 'no')
-# _WITH_OPENMP # Compile with OpenMPI (default: 'no')
-# _WITH_MPI # Compile with MPI (default: 'no')
+# _BUILD_DOC # Build documentation
+# _WITH_PLAUT04 # Build plaut04
+# _PLAUT04_WITH_QT # Build plaut04 with Qt (functionality is the same)
+# _AUTO_DEBUG # Compile with debug options
+# _WITH_OPENMP # Compile with OpenMPI
+# _WITH_MPI # Compile with MPI
#
# For using the environment variables controlling the build, also have a look at the sample script 'makepkg.sh' conbtained in the package.
#
###
-_pkgname="auto-07p"
-pkgname="${_pkgname}-git"
-_debianmainver=0.9.2
-_debiandfsgver=3
-_debianver="${_debianmainver}+dfsg-${_debiandfsgver}"
-_pkgver=latest
-pkgver=0.9.3+32.r.20230504.7042e6d
-pkgrel=1
-pkgdesc="Software for continuation and bifurcation problems in ordinary differential equations. Release 07P. Environment variables controlling build (default to 'no', see PKGBUILD): _BUILD_DOC, _WITH_PLAUT04, _PLAUT04_WITH_QT, AUTO_DEBUG, _WITH_OPENMP, _WITH_MPI."
-arch=('i686' 'x86_64')
-url='http://cmvl.cs.concordia.ca/auto/'
-options=('libtool' 'staticlibs')
-depends=(
- 'bash'
- # 'gcc-fortran' # May fail to build with gcc8 (see http://sourceforge.net/p/auto-07p/bugs/9/).
- 'g95' # Use 'g95' (Fortran compiler from GCC 4.0.3) instead of 'gcc-fortran'.
- 'gcc'
- 'python2'
- ) # A fortran compiler is needed during runtime for compilation of input files. 'gcc' is also needed, if the input files are C-files.
-makedepends=(
- # 'gcc-fortran' # May fail to build with gcc8 (see http://sourceforge.net/p/auto-07p/bugs/9/).
- 'g95' # Use 'g95' (Fortran compiler from GCC 4.0.3) instead of 'gcc-fortran'.
- 'gcc'
- 'git'
- )
-optdepends=(
- "python2-matplotlib: For python interface."
- "ipython2: For python interface."
- "lesstif: For GUI94 and PLAUT04."
- "openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')"
- "xterm: For PLAUT plotting interface."
- "soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
- "soqt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('soqt' can be used instead of 'soxt'. If using 'soqt', set '_PLAUT04_WITH_QT' to 'yes'.)"
- "coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
- "inventor: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('inventor' can be used instead of 'coin', but 'coin' (Coin3D) is recommended (see AUTO documentation).)"
- "openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'."
- "texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')."
- "transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes'))."
- ) ### Note: Some of these are optional at build time, but once a feature is build in (by './configure' automatically detecting the corresponding libraries), the packages are required to actual run AUTO, so they are _no_ optdepends for the binary package, just for the source.
-conflicts=("${_pkgname}")
-replaces=("${_pkgname}<=${pkgver}")
-provides=("${_pkgname}=${pkgver}")
-license=(
- 'BSD'
- 'LGPL2.1'
- 'GPL2'
- )
-source=(
- # "auto-07p::https://http.debian.net/debian/pool/main/a/auto-07p/auto-07p_${_debianmainver}+dfsg.orig.tar.gz"
- # "auto-07p::git+https://salsa.debian.org/science-team/auto-07p.git"
- # "auto-07p::git+https://github.com/andram/auto-07p.git#branch=python3fixes"
- "auto-07p::git+https://github.com/auto-07p/auto-07p.git"
- "auto-07p_debian.tar.xz::https://deb.debian.org/debian/pool/main/a/auto-07p/auto-07p_${_debianver}.debian.tar.xz" # Debian patches.
- "auto-07p-session.bash"
- "xpdf-dummy"
- "makepkg.sh" # Just a dummy script for reference purposes. It is _not_ run with this PKGBUILD, but it can be used to build this package with makepkg.
- )
-
-sha256sums=(
- 'SKIP'
- 'a5193041895eb79912f4932d8de234d1d7ba7d7b8eb0acb7ccc0c6c0e2cf25a5'
- '14d272315859abb260208cfc0a437ff41d66b22960180cfa9c80161e7dded3f4'
- 'cc83e032003bd9b79eaaee2bd91f77767caf55741ce02e9556dd49142ee1e911'
- '73bef420fdebb6b86b358bcd0f3d86e86f6963e76c7ae281391ec76a940c7644'
- )
+### Set defaults if not specified in the environment:
[ -n "${_BUILD_DOC}" ] || { # Building documentation can be controlled by environment variable.
- _BUILD_DOC=no # Controls if we want to build the documentation. Set to 'yes' to build it (requires some LaTeX-tools to be installed).
+ _BUILD_DOC=yes # Controls if we want to build the documentation. Set to 'yes' to build it (requires some LaTeX-tools to be installed).
}
-
[ -n "${_WITH_PLAUT04}" ] || { # Building plaut04 can be controlled by environment variable.
- _WITH_PLAUT04=no # Controls if we want to build plaut04. This is here since on my machine it fails even with 'coin' and 'soqt' installed, so I can explicitly disable it (default is disabled). Set to 'yes' to enable.
+ _WITH_PLAUT04=yes # Controls if we want to build plaut04. This is here since on my machine it fails even with 'coin' and 'soqt' installed, so I can explicitly disable it (default is disabled). Set to 'yes' to enable.
}
-
[ -n "${_PLAUT04_WITH_QT}" ] || { # Controls if plaut04 (if built) is built using qt-libs ('soqt', in that case), or not ('soxt', then).
- _PLAUT04_WITH_QT=no
+ _PLAUT04_WITH_QT=yes
}
-
[ -n "${_AUTO_DEBUG}" ] || { # Building with debugging options can be controlled by environment variable.
_AUTO_DEBUG=no # Controls if we want to build with debugging information. It will affect both the precompiled AUTO-libraries as well as the runtime-compilation of AUTO-input-files when running AUTO. Set to 'yes' to enable.
}
-
[ -n "${_WITH_OPENMP}" ] || { # Control the built of openmp-support.
- _WITH_OPENMP=no
+ _WITH_OPENMP=yes
}
-
[ -n "${_WITH_MPI}" ] || { # Control the build of MPI-support.
- _WITH_MPI=no
+ _WITH_MPI=yes
}
-# set the fortran compiler to use.
-FC='gfortran' # May Fail to build with gcc8 (see http://sourceforge.net/p/auto-07p/bugs/9/).
-# FC='gfortran-6'
-# FC='g95'
-export FC
-
-if [ "${_AUTO_DEBUG}x" == "yesx" ]; then
- # _FDEBUG_FLAGS="-ggdb -g -fbacktrace -fcheck=array-temps -fcheck=do -fcheck=mem -fcheck=pointer -fcheck=recursion" # Those are for 'new' gfortran.
- _FDEBUG_FLAGS="-ggdb -g" # Those are for g95.
- # -fcheck=bounds does NOT work, since AUTO itself violates bounds ... a bug in AUTO with sideeffects, without sideeffects, or even needed??
- _CDEBUG_FLAGS="-ggdb -g"
- _CXXDEBUG_FLAGS="-ggdb -g"
- _OPT_FLAGS="-O0"
- options+=('!strip')
+
+_pkgname="auto-07p"
+pkgname="${_pkgname}-git"
+_debianmainver=0.9.2
+_debiandfsgver=3
+_debianver="${_debianmainver}+dfsg-${_debiandfsgver}"
+_pkgver=latest
+pkgver=0.9.3+32.r.20230504.7042e6d
+pkgrel=2
+pkgdesc="Software for continuation and bifurcation problems in ordinary differential equations. Version 07p, latest git checkout. Environment variables can control the build (see PKGBUILD)."
+arch=(
+ 'aarch64'
+ 'armv7h'
+ 'armv8h'
+ 'i686'
+ 'x86_64'
+)
+url='http://cmvl.cs.concordia.ca/auto/'
+# url='https://github.com/auto-07p/auto-07p'
+options=(
+ 'libtool'
+ 'staticlibs'
+)
+depends=(
+ 'bash'
+ 'gcc-fortran'
+ # 'gcc6-fortran'
+ # 'g95' # Use 'g95' (Fortran compiler from GCC 4.0.3) instead of 'gcc-fortran'.
+ 'gcc'
+ 'gcc-libs'
+ 'glibc'
+ 'libice'
+ 'libsm'
+ 'libxt'
+ 'libx11'
+ 'openmotif'
+ 'xterm' # For PLAUT plotting interface.
+) # NOTE: A fortran compiler is needed during runtime for compilation of input files. 'gcc' is also needed, if the input files are C-files.
+makedepends=(
+ 'git'
+ 'perl'
+)
+# checkdepends=(
+# "python3"
+# ) # `make check` takes long and might fail.
+optdepends=(
+ "ipython: For python interface."
+ "python3: For python interface."
+ "python-matplotlib: For python interface."
+ 'python-numpy: For python interface.'
+ "python-traitlets: For python interface."
+)
+conflicts=(
+ "${_pkgname}"
+)
+replaces=()
+provides=(
+ "${_pkgname}=${pkgver}"
+)
+license=(
+ 'BSD'
+ 'LGPL2.1'
+ 'GPL2'
+)
+source=(
+ "auto-07p::git+https://github.com/auto-07p/auto-07p.git"
+ "auto-07p_${_debianver}.debian.tar.xz::https://deb.debian.org/debian/pool/main/a/auto-07p/auto-07p_${_debianver}.debian.tar.xz" # Debian patches.
+ "auto-07p-session.bash"
+ "xpdf-dummy"
+ "makepkg.sh" # Just a dummy script for reference purposes. It is _not_ run with this PKGBUILD, but it can be used to build this package with makepkg.
+)
+
+sha256sums=(
+ 'SKIP'
+ 'a5193041895eb79912f4932d8de234d1d7ba7d7b8eb0acb7ccc0c6c0e2cf25a5'
+ '14d272315859abb260208cfc0a437ff41d66b22960180cfa9c80161e7dded3f4'
+ 'cc83e032003bd9b79eaaee2bd91f77767caf55741ce02e9556dd49142ee1e911'
+ '73bef420fdebb6b86b358bcd0f3d86e86f6963e76c7ae281391ec76a940c7644'
+)
+
+if [ "y${_BUILD_DOC}" == "yyes" ]; then
+ makedepends+=(
+ "texlive-bin" # For compiling the manual.
+ "transfig" # For compiling the manual."
+ )
+fi
+if [ "y${_WITH_PLAUT04}" == "yyes" ]; then
+ depends+=(
+ "coin" # For plaut04 plotting interface.
+ )
+ if [ "y${_PLAUT04_WITH_QT}" == "yyes" ]; then
+ depends+=(
+ "soqt" # For PLAUT04 plotting interface.
+ )
+ else
+ depends+=(
+ "soxt" # For PLAUT04 plotting interface.
+ )
+ fi
+fi
+if [ "y${_WITH_OPENMP}" == "yyes" ]; then
+ depends+=(
+ "openmp" # For parallel computation with OpenMP
+ )
+fi
+if [ "y${_WITH_MPI}" == "yyes" ]; then
+ depends+=(
+ "openmpi" # For MPI message passing (parallel computation).
+ )
+fi
+if [ "y${_AUTO_DEBUG}" == "yyes" ]; then
+ options+=('!lto' 'debug' '!strip')
+ export CFLAGS="-Og -ggdb3 -g3 ${DEBUG_CFLAGS}"
+ export CXXFLAGS="-Og -ggdb3 -g3 ${DEBUG_CXXFLAGS}"
+ export FFLAGS="-ggdb3"
+ export _OPT_FLAGS="-Og -g3 -ggdb3"
else
- _FDEBUG_FLAGS="-g0"
- _CDEBUG_FLAGS="-g0"
- _CXXDEBUG_FLAGS="-g0"
- _OPT_FLAGS="-O3"
+ export _OPT_FLAGS="-O3"
fi
-# FFLAGS+=" ${_FDEBUG_FLAGS} -std=legacy" # '-std=legacy': See https://sourceforge.net/p/auto-07p/bugs/9/ # This is for 'new' gfortran.
-FFLAGS+=" ${_FDEBUG_FLAGS}" # This is for g95.
-CFLAGS+=" ${_CDEBUG_FLAGS}"
-CXXFLAGS+=" ${_CXXDEBUG_FLAGS}"
+export CFLAGS="${CFLAGS} -Wno-error=unused-result"
+export CXXFLAGS="${CXXFLAGS} -Wno-error=unused-result"
+# export FFLAGS="${FFLAGS} -std=legacy" # '-std=legacy': See https://sourceforge.net/p/auto-07p/bugs/9/ # This is for 'new' gfortran.
-export FFLAGS
-export CFLAGS
-export CXXFLAGS
+# set the fortran compiler to use.
+export FC='gfortran'
+# export FC='gfortran-6'
+# export FC='g95'
+export MPIFC='mpifort'
+# export MPIFC='mpif90'
-prepare()
-{
+prepare() {
cd "${srcdir}"
mkdir -pv 'auto'
mv -v 'auto-07p' 'auto/07p'
@@ -150,14 +181,24 @@ prepare()
_debianpatchdir="${srcdir}/debian/patches"
cd "${_extractdir}"
+ git log > git.log
+
for _deb_patch in '02_env.patch'; do
msg2 ">> Applying debian patch ${_deb_patch} ..."
patch --follow-symlinks -N -p2 -i "${_debianpatchdir}/${_deb_patch}"
done
+
+ ### Since building the documentation opens the finished pdf with xpdf, we have a dummy xpdf-executable that does nothing. Set it up here to use it.
+ cd "${srcdir}"
+ if ! [ -e xpdf ]; then
+ ln -s xpdf-dummy xpdf
+ fi
+ chmod a+x xpdf-dummy xpdf
+ export _OLDPATH="${PATH}"
+ export PATH="${srcdir}:${PATH}"
}
-pkgver()
-{
+pkgver() {
_extractdir="${srcdir}/auto/07p"
cd "${_extractdir}"
_ver="$(git describe --tags | sed -E -e 's|^[vV]||' -e 's|-g[0-9a-f]*$||' | tr '-' '+')"
@@ -178,58 +219,23 @@ pkgver()
printf '%s' "${_ver}.r${_rev}.${_date}.${_hash}"
}
-_build_documentation()
-{
+_build_documentation() {
msg2 ">> Building documentation for '${pkgname}', version '${pkgver}'. >>"
- ### Since building the documentation opens the finished pdf with xpdf, we have a dummy xpdf-executable that does nothing. Set it up here to use it.
- cd "${srcdir}"
- ln -s xpdf-dummy xpdf
- chmod a+x xpdf-dummy xpdf
- _OLDPATH="${PATH}"
- PATH="${srcdir}:${PATH}"
- export PATH
-
- ### Now, we are ready to build the documentation without the annoying xpdf-startup.
- cd "${_docdir}" || exit 201
+ _docdir="${_extractdir}/doc"
+ cd "${_docdir}"
- make all || exit "$?"
-
- ### Reset the PATH to the value it had before.
- PATH="${_OLDPATH}"
- export PATH
+ make all
msg2 "<< Finished building documentation for '${pkgname}', version '${pkgver}'. <<"
}
-_install_documentation()
-{
- ### Documentation gets already installed by the normal install procedure, since everything is copied anyway. So, do nothing here. ###
- true
-
-# msg2 ">> Packaging documentation for '${pkgname}', version '${pkgver}'. >>"
-#
-#
-# mkdir -p "${_doc_install_dir}" || exit 301
-# mkdir -p "${_plaut04_doc_install_dir}" || exit 302
-#
-# if [ -e "${_docdir}/auto.pdf" ]; then
-# cp -a "${_docdir}/auto.pdf" "${_doc_install_dir}/" || exit "$?"
-# fi
-# if [ -e "${_plaut04docdir}/userguide.pdf" ]; then
-# cp -a "${_plaut04docdir}/userguide.pdf" "${_plaut04_doc_install_dir}/" || exit "$?"
-# fi
-#
-# msg2 "<< Finished packaging documentation for '${pkgname}', version '${pkgver}'. <<"
-}
-
-build()
-{
+build() {
_extractdir="${srcdir}/auto/07p"
_docdir="${_extractdir}/doc"
_plaut04docdir="${_extractdir}/plaut04/doc"
- _install_location="/opt/auto/07p" # Since AUTO does not provide it's own installation procedure we have to take care of it. And since AUTO wants to have it's files somewhat unter one place, we can not just install binaries to '/usr/bin', libraries to '/usr/lib', documentation to '/usr/share/doc' and custom commands somewhere else. To keep everything together, we install into '/opt/auto/07p', and have a shell script which starts a shell session with correctly set environment variables, which we place in '/usr/bin'.
+ _install_location="/opt/auto/07p" # Since AUTO does not provide it's own installation procedure we have to take care of it. And since AUTO wants to have it's files somewhat under one place, we can not just install binaries to '/usr/bin', libraries to '/usr/lib', documentation to '/usr/share/doc' and custom commands somewhere else. To keep everything together, we install into '/opt/auto/07p', and have a shell script which starts a shell session with correctly set environment variables, which we place in '/usr/bin'.
_install_dir="${pkgdir}/${_install_location}"
_doc_install_dir="${_install_dir}/doc"
@@ -239,10 +245,9 @@ build()
export AUTO_DIR
-
msg2 ">>> Building '${pkgname}', version '${pkgver}'. >>>"
- cd "${_extractdir}" || exit 11
+ cd "${_extractdir}"
if [ "y${_WITH_PLAUT04}" == "yyes" ]; then
if [ "y${_PLAUT04_WITH_QT}" == "yyes" ]; then
@@ -254,13 +259,13 @@ build()
else
_plaut04_config="--disable-plaut04 --disable-plaut04-qt"
fi
-
+
if [ "y${_WITH_OPENMP}" == "yyes" ]; then
_openmp_config="--with-openmp"
else
_openmp_config="--without-openmp"
fi
-
+
if [ "y${_WITH_MPI}" == "yyes" ]; then
_mpi_config="--with-mpi"
else
@@ -268,31 +273,46 @@ build()
fi
msg2 ">> Running 'configure'-script for '${pkgname}', version '${pkgver}'. >>"
-
- ./configure --enable-plaut ${_plaut04_config} ${_openmp_config} ${_mpi_config} --enable-gui --enable-tek2ps --with-x --with-optimization-flags="${_OPT_FLAGS}" --prefix="${_install_location}" FC="${FC}" FFLAGS="${FFLAGS}" CFLAGS="${CFLAGS}" || exit "$?"
- ### Remakrs for 'copenmotif: For GUI94. ('openmotif' can be used instead of 'lesstif'nfigure'-script: ###
+
+ ./configure \
+ --enable-plaut \
+ ${_plaut04_config} \
+ ${_openmp_config} \
+ ${_mpi_config} \
+ --enable-gui \
+ --with-x \
+ --with-optimization-flags="${_OPT_FLAGS}" \
+ --prefix="${_install_location}" \
+ FC="${FC}" \
+ MPIFC="${MPIFC}" \
+ FFLAGS="${FFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}"
+ ### Remakrs for './configure' script:
# * '--prefix' seems to be obsolete since there is no 'make install'. Specified anyway, since I do not know if it gets configured somewhere where it is used later.
- # * For some reason, enabling plaut04 breaks build (installed packages on my machine: 'coin' and 'soqt' and 'simage', although 'simage' is, according to the AUTO-documentation, not necessary for 'soqt' version >= 1.5.0.)
### /Remarks for 'configure'-script. ###
msg2 "<< Finished running 'configure'-script for '${pkgname}', version '${pkgver}'. <<"
-
msg2 ">> Running 'make'-script for '${pkgname}', version '${pkgver}'. >>"
- make || exit "$?"
+ make
msg2 "<< Finished running 'make'-script for '${pkgname}', version '${pkgver}'. <<"
if [ "y${_BUILD_DOC}" == "yyes" ]; then
- _build_documentation || exit "$?" # IMPORTANT!, build documentation _after_ main build, otherwise there will no main build happen.
+ _build_documentation # IMPORTANT!, build documentation _after_ main build, otherwise there will no main build happen.
fi
msg2 "<<< Finished building '${pkgname}', version '${pkgver}'. <<<"
}
-package()
-{
+# check() {
+# cd "${_extractdir}"
+# make check # `make check` takes long and might fail.
+# }
+
+package() {
_extractdir="${srcdir}/auto/07p"
_docdir="${_extractdir}/doc"
_plaut04docdir="${_extractdir}/plaut04/doc"
@@ -307,48 +327,28 @@ package()
export AUTO_DIR
msg2 ">>> Installing '${pkgname}', version '${pkgver}', into package dir '${pkgdir}'. >>>"
- cd "${_extractdir}" || exit 101
+ cd "${_extractdir}"
- mkdir -p "${_install_dir}" || exit "$?"
+ install -dvm755 "${_install_dir}"
ls -A1 "${_extractdir}"/ | while read _content; do # Copy everything, including files starting with ".", but not the special directory entries "." and "..". We do _not_ use an extra argument to "cp" to solve this in order to avoid error messages if there are no dotfiles.
- cp -a -t "${_install_dir}" "${_content}" || exit "$?"
- done || exit "$?"
+ cp -a -t "${_install_dir}" "${_content}"
+ done
+ rm -Rf "${_install_dir}"/{.git,.gitignore,.github}
- mkdir -p "${pkgdir}/usr/bin" || exit "$?"
- cp -aL "${srcdir}/auto-07p-session.bash" "${pkgdir}/usr/bin/" || exit "$?"
+ install -dvm755 "${pkgdir}/usr/bin"
+ cp -aL "${srcdir}/auto-07p-session.bash" "${pkgdir}/usr/bin/"
- if [ "y${_BUILD_DOC}" == y"yes" ]; then
- _install_documentation || exit "$?"
- fi
+ install -dvm755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ for _docfile in git.log CHANGELOG README; do
+ ln -svr "${_install_dir}/${_docfile}" "${pkgdir}/usr/share/doc/${_pkgname}/${_docfile}"
+ done
+ ln -svr "${_doc_install_dir}" "${pkgdir}/usr/share/doc/${_pkgname}/auto-doc"
+ ln -svr "${_plaut04_doc_install_dir}" "${pkgdir}/usr/share/doc/${_pkgname}/plaut04-doc"
- rm -f "${_install_dir}/plaut"/*.o "${_install_dir}/plaut"/*.mod "${_install_dir}/plaut04"/*.mod "${_install_dir}/plaut04"/*.mod "${_install_dir}/gui"/*.o "${_install_dir}/tek2ps"/*.o "${_install_dir}/install-sh" "${_install_dir}/config.status" "${_install_dir}/cmds/auto.env" "${_install_dir}/cmds/auto.env.sh" || exit "$?" # Remove files we don't want to have.
+ rm -f "${_install_dir}/plaut"/*.o "${_install_dir}/plaut"/*.mod "${_install_dir}/plaut04"/*.mod "${_install_dir}/plaut04"/*.mod "${_install_dir}/gui"/*.o "${_install_dir}/tek2ps"/*.o "${_install_dir}/install-sh" "${_install_dir}/config.status" "${_install_dir}/cmds/auto.env" "${_install_dir}/cmds/auto.env.sh" # Remove files we don't want to have.
- chown -R root:root "${pkgdir}" || exit "$?"
+ chown -R root:root "${pkgdir}"
msg2 "<<< Finished installing '${pkgname}', version '${pkgver}', into package dir '${pkgdir}'. <<<"
-
-# msg2 ">>> patching shabeng-lines of python scripts from 'python' to 'python2'. >>>"
-#
-# cd "${_install_dir}"
-# ### The "grep" just filters out the files which _may_ be needed to patch (note, that it also matches non-first lines but we only want to patch the first line).
-# ### Then, the "sed"-command takes care of just patching the first line.
-# ### We could omit the "grep" and simply run "sed" over all files, but that would be too much (and more prone for programming errors becoming effective).
-# grep -rlE '^\#\!.*python\>' "${_install_dir}"/* | while read _file; do
-# sed -i '1s|python\(\>\)|python2\1|g' "${_file}"
-# done
-#
-# msg2 "<<< Finished patching shabeng-lines of python scripts from 'python' to 'python2'. <<<"
-#
-# msg2 ">>> patching 'exec python' to 'exec python2'. >>>"
-#
-# ### The "grep" just filters out the files which _may_ be needed to patch.
-# ### Then, the "sed"-command takes care of patching.
-# ### Indeed, the grep could be omitted, but it's another step of security to not mis-patch.
-# ### (Actually, bin/autox is the only file which gets patched at all.)
-# grep -rwlE 'exec[[:space:]]+python' "${_install_dir}"/* | while read _file; do
-# sed -ri 's|\<exec[[:space:]]+python\>|exec python2|g' "${_file}"
-# done
-#
-# msg2 "Finished patching 'exec python' to 'exec python2'. <<<"
}