summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2015-06-14 02:01:14 -0300
committerVinícius dos Santos Oliveira2015-06-14 02:01:14 -0300
commit6ec7373ef56895b6ac6ad67f391125cf82859be2 (patch)
treec477e7f585bcfda6972ff267dbabfe112cb8af6f
downloadaur-6ec7373ef56895b6ac6ad67f391125cf82859be2.tar.gz
Genesis commit
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD30
-rwxr-xr-xauto-complete-clang-async.install27
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d1743892b11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = auto-complete-clang-async
+ pkgdesc = An emacs plugin to complete C and C++ code using libclang
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/Golevka/emacs-clang-complete-async
+ install = auto-complete-clang-async.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = emacs
+ depends = auto-complete
+ depends = clang
+ source = git+https://github.com/Golevka/emacs-clang-complete-async.git#tag=v0.5
+ md5sums = SKIP
+
+pkgname = auto-complete-clang-async
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8138b8677664
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+
+pkgname=auto-complete-clang-async
+pkgver=0.5
+pkgrel=1
+pkgdesc="An emacs plugin to complete C and C++ code using libclang"
+arch=('i686' 'x86_64')
+url="https://github.com/Golevka/emacs-clang-complete-async"
+license=('GPL')
+install=$pkgname.install
+depends=('emacs' 'auto-complete' 'clang')
+makedepends=('git')
+source=("git+https://github.com/Golevka/emacs-clang-complete-async.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/emacs-clang-complete-async"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/"
+ mkdir -p "${pkgdir}/usr/bin"
+
+ cp "${srcdir}/emacs-clang-complete-async/clang-complete" "${pkgdir}/usr/bin"
+ cp -rp "${srcdir}/emacs-clang-complete-async/auto-complete-clang-async.el" \
+ "${pkgdir}/usr/share/emacs/site-lisp"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/auto-complete-clang-async.install b/auto-complete-clang-async.install
new file mode 100755
index 000000000000..e875005817c3
--- /dev/null
+++ b/auto-complete-clang-async.install
@@ -0,0 +1,27 @@
+post_install()
+{
+cat << EOF
+add the following lines to your .emacs
+===================================================================
+(require 'auto-complete-clang-async)
+
+(defun ac-cc-mode-setup ()
+ (setq ac-clang-complete-executable "~/.emacs.d/clang-complete")
+ (setq ac-sources '(ac-source-clang-async))
+ (ac-clang-launch-completion-process)
+)
+
+(defun my-ac-config ()
+ (add-hook 'c-mode-common-hook 'ac-cc-mode-setup)
+ (add-hook 'auto-complete-mode-hook 'ac-common-setup)
+ (global-auto-complete-mode t))
+
+(my-ac-config)
+===================================================================
+EOF
+}
+
+post_upgrade()
+{
+ post_install
+}