summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYang Bai2015-07-02 18:16:52 +0800
committerYang Bai2015-07-02 18:16:52 +0800
commit5c2a1d5eab1ed3b2c2104d2d7c087614e9ed529a (patch)
treeeef3029e1a9cc4c8e189b2d6bbbb9164a6e0cc5b
downloadaur-auto-complete-clang-async-bin.tar.gz
20140918-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d20cb8c1dc3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = auto-complete-clang-async-bin
+ pkgdesc = emacs-clang-complete-async is an emacs extension to complete C and C++ code, it uses libclang to parse the source code on the fly and provides completion candidates to auto-complete (binary only)
+ pkgver = 20140918
+ pkgrel = 1
+ url = https://github.com/Golevka/emacs-clang-complete-async
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = clang
+ source = git+https://github.com/Golevka/emacs-clang-complete-async.git
+ md5sums = SKIP
+
+pkgname = auto-complete-clang-async-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68b84b62586c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yang Bai <hamo.by@gmail.com>
+# Contributor: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+
+pkgname=auto-complete-clang-async-bin
+pkgver=20140918
+pkgrel=1
+pkgdesc="emacs-clang-complete-async is an emacs extension to complete C and C++ code, it uses libclang to parse the source code on the fly and provides completion candidates to auto-complete (binary only)"
+arch=('i686' 'x86_64')
+url="https://github.com/Golevka/emacs-clang-complete-async"
+license=('GPL')
+depends=('clang')
+makedepends=('git')
+source=("git+https://github.com/Golevka/emacs-clang-complete-async.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/emacs-clang-complete-async"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+
+ cp "${srcdir}/emacs-clang-complete-async/clang-complete" "${pkgdir}/usr/bin"
+}