summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 17:58:33 -0400
committergraysky2015-06-08 17:58:33 -0400
commit57ab0047627be13a5a0dae7008007378cfcac7e1 (patch)
tree4f3991161cae6406bbf87325d5f17d1cf7a3696b
downloadaur-57ab0047627be13a5a0dae7008007378cfcac7e1.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4c74c42e156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = auto-reencode
+ pkgdesc = Mass convert any format readable by handbrake to mp4 contained x264.
+ pkgver = 2.75
+ pkgrel = 1
+ url = https://github.com/graysky2/auto-reencode
+ arch = any
+ license = MIT
+ depends = mediainfo>=0.7.2
+ depends = handbrake-cli
+ conflicts = autoflv2x264
+ replaces = autoflv2x264
+ source = http://repo-ck.com/source/auto-reencode/auto-reencode-2.75.tar.xz
+ sha256sums = 51c26ee98663e101f2a125e386d785aa3276a5876d5b4d88844d1444f90d4a89
+
+pkgname = auto-reencode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc4bb6820db1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: graysky <graysky AT archlinux dot us>
+
+pkgname=auto-reencode
+arch=('any')
+license=('MIT')
+pkgver=2.75
+pkgrel=1
+pkgdesc="Mass convert any format readable by handbrake to mp4 contained x264."
+conflicts=('autoflv2x264')
+replaces=('autoflv2x264')
+depends=('mediainfo>=0.7.2' 'handbrake-cli')
+url="https://github.com/graysky2/auto-reencode"
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+sha256sums=('51c26ee98663e101f2a125e386d785aa3276a5876d5b4d88844d1444f90d4a89')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}