summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjjacky2012-02-07 15:41:26 +0100
committerOlivier Brunel2015-06-08 18:45:33 +0200
commit41229dd63130737db93e1024d0c43e1af170aece (patch)
treed02b60e927b0f5385043e9962b2386055429136d
downloadaur-41229dd63130737db93e1024d0c43e1af170aece.tar.gz
first commit
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--install9
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11fa928a5a1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = auto-rsync-backups
+ pkgdesc = little script to handle/rotate rsync backups
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://bitbucket.org/jjacky/backups
+ install = install
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = rsync
+ source = https://bitbucket.org/jjacky/backups/get/0.2.tar.gz
+ md5sums = 013edc9f160098e27bd94b9ec754c7e7
+
+pkgname = auto-rsync-backups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec835efc6264
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: jjacky
+pkgname=auto-rsync-backups
+pkgver=0.2
+pkgrel=1
+pkgdesc="little script to handle/rotate rsync backups"
+arch=('any')
+url="https://bitbucket.org/jjacky/backups"
+license=('GPL3')
+depends=('bash' 'rsync')
+install='install'
+source=(https://bitbucket.org/jjacky/backups/get/$pkgver.tar.gz)
+
+package() {
+ cd "$srcdir/jjacky-backups-$pkgver/src"
+ install -D -m755 backups.sh "${pkgdir}/usr/bin/backups.sh"
+ install -D -m755 restore.sh "${pkgdir}/usr/bin/restore.sh"
+ install -D -m644 backups.common "${pkgdir}/usr/bin/backups.common"
+ install -D -m644 backups.sample.conf "${pkgdir}/usr/share/${pkgname}/backups.conf"
+ install -D -m644 backups.excludes "${pkgdir}/usr/share/${pkgname}/backups.excludes"
+}
+
+md5sums=('013edc9f160098e27bd94b9ec754c7e7')
diff --git a/install b/install
new file mode 100644
index 000000000000..f3a75f909326
--- /dev/null
+++ b/install
@@ -0,0 +1,9 @@
+
+post_install() {
+ cat <<EOF
+ You can now use backups.sh and restore.sh
+ An example of configuration file is available as /usr/share/auto-rsync-backups/backups.conf
+ An example of excludes file is available as /usr/share/auto-rsync-backups/backups.exclude
+EOF
+}
+