summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodl (Corentin Delcourt)2015-06-08 14:13:13 +0200
committercodl (Corentin Delcourt)2015-06-08 14:13:13 +0200
commitf7628b4e4f46c1697faf24ceb056dad9c5760b1e (patch)
treed410c4232d5f1ebfc22ac1f45dbaf1c615d1ff2c
downloadaur-f7628b4e4f46c1697faf24ceb056dad9c5760b1e.tar.gz
imported from original package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--autocutsel.install20
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0021183b7a34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = autocutsel-git
+ pkgdesc = Synchronizes the two copy/paste buffers mainly used by X applications
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = http://www.nongnu.org/autocutsel/
+ install = autocutsel.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxaw
+ provides = autocutsel
+ conflicts = autocutsel
+ source = autocutsel-git::git+https://github.com/sigmike/autocutsel.git
+ source = autocutsel.install
+ md5sums = SKIP
+ md5sums = d5616ff1b64c78473c02a4d8c88675bd
+
+pkgname = autocutsel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e11ff81412ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Corentin Delcourt <aur@codl.fr>
+
+pkgname=autocutsel-git
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Synchronizes the two copy/paste buffers mainly used by X applications"
+arch=(i686 x86_64)
+url='http://www.nongnu.org/autocutsel/'
+install=autocutsel.install
+depends=('libxaw')
+license=('GPL')
+provides=('autocutsel')
+conflicts=('autocutsel')
+source=("${pkgname}"::'git+https://github.com/sigmike/autocutsel.git'
+ 'autocutsel.install')
+md5sums=('SKIP'
+ 'd5616ff1b64c78473c02a4d8c88675bd')
+
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --tags | sed -e 's:v::' -e 's/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make prefix="${pkgdir}/usr" install
+}
diff --git a/autocutsel.install b/autocutsel.install
new file mode 100644
index 000000000000..56fde35d7bf8
--- /dev/null
+++ b/autocutsel.install
@@ -0,0 +1,20 @@
+post_install() {
+ cat << EOF
+ Add the following lines to your ~/.xinitrc or, for
+ system-wide use, to a new file, named, say, 40-autocutsel
+ in the directory /etc/X11/xinit/xinitrc.d/ :
+
+autocutsel -fork &
+autocutsel -selection PRIMARY -fork &
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
+post_remove() {
+cat << EOF
+ you might want to remove autocutsel related files in
+ /etc/X11/xinit/xinitrc.d now.
+EOF
+}