summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-10-24 14:18:05 +0100
committerHans-Nikolai Viessmann2018-10-24 14:18:05 +0100
commit03abf712cbb22659b39b21fa918147e1c85993c8 (patch)
tree4f79810fe7052c0cb06fbeb3f05c2da7f8d45263
parent7529b9f7b76176cdf5f0bacca64222bae3209dd3 (diff)
downloadaur-03abf712cbb22659b39b21fa918147e1c85993c8.tar.gz
bump to 2.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md49
-rw-r--r--PKGBUILD12
3 files changed, 58 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ba923c8027e..104e4901a702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = autodl-irssi-community
pkgdesc = Community fork of the plugin for irssi which monitors IRC announce channels and downloads torrents based on user defined filters.
- pkgver = 2.0.1
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/autodl-community/autodl-irssi
install = autodl-irssi-community.install
@@ -19,8 +19,8 @@ pkgbase = autodl-irssi-community
provides = autodl-irssi
conflicts = autodl-irssi-svn
replaces = autodl-irssi-svn
- source = https://github.com/autodl-community/autodl-irssi/archive/community-v2.0.1.tar.gz
- md5sums = 6fbfb0d4e0ee01156b444c5fdeaf55ca
+ source = https://github.com/autodl-community/autodl-irssi/archive/2.4.0.tar.gz
+ md5sums = c7c235d64e91b27d2a0902c3a80ff119
pkgname = autodl-irssi-community
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 9c5c0db14600..c56d5a01c7f2 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,6 +3,55 @@
Notable changes for [autodl-irssi](https://github.com/autodl-community/autodl-irssi).
+## [v2.4.0](https://github.com/autodl-community/autodl-irssi/releases/tag/v2.4.0) (2018-09-08)
+
+[Commits](https://github.com/autodl-community/autodl-irssi/compare/v2.3.0...v2.4.0)
+
+**The maintainer no longer provides support. Look to other users for help.**
+
+
+## [v2.3.0](https://github.com/autodl-community/autodl-irssi/releases/tag/v2.3.0) (2018-03-10)
+
+[Commits](https://github.com/autodl-community/autodl-irssi/compare/v2.2.0...v2.3.0)
+
+### Added
+
+* Add "h264 10-bit to constants.
+* Add constant group for h265/x265 10-bit.
+* Add "Lossless 24-bit" to constants.
+* Add WMA to constants.
+* Add TrueHD to constants.
+
+
+## [v2.2.0](https://github.com/autodl-community/autodl-irssi/releases/tag/v2.2.0) (2018-01-30)
+
+[Commits](https://github.com/autodl-community/autodl-irssi/compare/v2.1.0...v2.2.0)
+
+### Changed
+
+* Change censor placeholders to be more specific.
+* Make auto updates the default.
+
+### Fixed
+
+* Make censor regex work with or without trailing slash.
+* Don't overwrite already set variables in auto extractor.
+
+
+## [v2.1.0](https://github.com/autodl-community/autodl-irssi/releases/tag/v2.1.0) (2018-01-19)
+
+[Commits](https://github.com/autodl-community/autodl-irssi/compare/community-v2.0.1...v2.1.0)
+
+### Added
+
+* Add 4k alias for 2160p resolution.
+
+### Changed
+
+* Split up remux encoders.
+* Use proper size unit prefixes in status messages.
+
+
## [community-v2.0.1](https://github.com/autodl-community/autodl-irssi/releases/tag/community-v2.0.1) (2017-12-14)
[Commits](https://github.com/autodl-community/autodl-irssi/compare/community-v2.0.0...community-v2.0.1)
diff --git a/PKGBUILD b/PKGBUILD
index 71b380cc4885..ff458866c8fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='autodl-irssi'
pkgname="${_pkgname}-community"
-pkgver=2.0.1
+pkgver=2.4.0
pkgrel=1
pkgdesc='Community fork of the plugin for irssi which monitors IRC announce channels and downloads torrents based on user defined filters.'
arch=('any')
@@ -22,18 +22,18 @@ install="${pkgname}.install"
provides=("${_pkgname}")
replaces=("autodl-irssi-svn")
conflicts=("autodl-irssi-svn")
-source=("https://github.com/autodl-community/${_pkgname}/archive/community-v${pkgver}.tar.gz")
-md5sums=('6fbfb0d4e0ee01156b444c5fdeaf55ca')
+source=("https://github.com/autodl-community/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('c7c235d64e91b27d2a0902c3a80ff119')
package() {
- cd "$srcdir/${pkgname}-v${pkgver}"
+ cd "$srcdir/${_pkgname}-${pkgver}"
- install -dm755 "$pkgdir/usr/share/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/$_pkgname"
# copy over all the IRC/tracker files
cp -r "AutodlIrssi" "$pkgdir/usr/share/$_pkgname/"
chmod 755 "$pkgdir/usr/share/$_pkgname/AutodlIrssi"
-
+
install -Dm644 "autodl-irssi.pl" "$pkgdir/usr/share/$_pkgname"
install -Dm644 "README.md" "$pkgdir/usr/share/$_pkgname"
}