summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2017-04-27 12:30:22 +0100
committerHans-Nikolai Viessmann2017-04-27 12:30:22 +0100
commitb177ba23ca94092a7b360cf7ca52f4c8456044e9 (patch)
tree2e883017bf223deded2727448bd1d30459397f88
parent1b345f4e958b7957cf5a1bd12360c25ea69f80fe (diff)
downloadaur-b177ba23ca94092a7b360cf7ca52f4c8456044e9.tar.gz
Version bump to 1.64
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG.md32
-rw-r--r--PKGBUILD13
3 files changed, 39 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 230b654c175d..3cd2b5cf0e9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autodl-irssi-community
pkgdesc = Community fork of the plugin for irssi which monitors IRC announce channels and downloads torrents based on user defined filters.
- pkgver = 1.62
- pkgrel = 4
+ pkgver = 1.64
+ pkgrel = 1
url = https://github.com/autodl-community/autodl-irssi
install = autodl-irssi-community.install
changelog = CHANGELOG.md
@@ -17,12 +17,11 @@ pkgbase = autodl-irssi-community
depends = perl-json
depends = perl-json-xs
depends = perl-xml-libxslt
- optdepends = rutorrent-autodl-irssi-community: Community autodl-irssi plugin for rutorrent.
provides = autodl-irssi
conflicts = autodl-irssi-svn
replaces = autodl-irssi-svn
- source = https://github.com/autodl-community/autodl-irssi/releases/download/community-v1.62/autodl-irssi-community-v1.62.zip
- md5sums = 1fd5701578f69a293547fea7f697c6e1
+ source = https://github.com/autodl-community/autodl-irssi/archive/community-v1.64.tar.gz
+ md5sums = 6bc8c713949897b683a8811ed57ec40c
pkgname = autodl-irssi-community
diff --git a/CHANGELOG.md b/CHANGELOG.md
index a5a4fee5dded..8316abc62e7f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,13 +3,39 @@
Notable changes for the [autodl-irssi-community](https://github.com/autodl-community/autodl-irssi) project.
+## [community-v1.64](https://github.com/autodl-community/autodl-irssi/releases/tag/community-v1.64) (2017-03-18)
+
+[Commits](https://github.com/autodl-community/autodl-irssi/compare/community-v1.63...community-v1.64)
+
+### Added
+
+* Add HEVC/x265 constants.
+
+### Fixed
+
+* Fixed update callback references.
+
+
+## [community-v1.63](https://github.com/autodl-community/autodl-irssi/releases/tag/community-v1.63) (2017-03-09)
+
+[Commits](https://github.com/autodl-community/autodl-irssi/compare/community-v1.62...community-v1.63)
+
+### Changed
+
+* Add release to download history earlier in the process.
+
+### Fixed
+
+* Fix smart-episode logic.
+
+
## [community-v1.62](https://github.com/autodl-community/autodl-irssi/releases/tag/community-v1.62) (2016-03-14)
[Commits](https://github.com/autodl-community/autodl-irssi/compare/community-v1.61...community-v1.62)
### Added
-* Add smart-episode filter option
+* Add smart-episode filter option.
## [community-v1.61](https://github.com/autodl-community/autodl-irssi/releases/tag/community-v1.61) (2016-01-25)
@@ -19,11 +45,11 @@ Notable changes for the [autodl-irssi-community](https://github.com/autodl-commu
### Added
* Add priority filter option.
-* Add message for successful loading of configuration files
+* Add message for successful loading of configuration files.
### Changed
-* Changed method for matching release groups
+* Changed method for matching release groups.
## [community-v1.60](https://github.com/autodl-community/autodl-irssi/releases/tag/community-v1.60) (2015-10-01)
diff --git a/PKGBUILD b/PKGBUILD
index a5107c59275c..d78398441e71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname='autodl-irssi-community'
_pkgname='autodl-irssi'
-pkgver=1.62
-pkgrel=4
+pkgver=1.64
+pkgrel=1
pkgdesc='Community fork of the plugin for irssi which monitors IRC announce channels and downloads torrents based on user defined filters.'
arch=('any')
url='https://github.com/autodl-community/autodl-irssi'
@@ -20,15 +20,14 @@ depends=('irssi'
'perl-xml-libxslt')
makedepends=('git')
install="${pkgname}.install"
-optdepends=('rutorrent-autodl-irssi-community: Community autodl-irssi plugin for rutorrent.')
provides=("${_pkgname}")
replaces=("autodl-irssi-svn")
conflicts=("autodl-irssi-svn")
-source=("https://github.com/autodl-community/autodl-irssi/releases/download/community-v${pkgver}/${pkgname}-v${pkgver}.zip")
-md5sums=('1fd5701578f69a293547fea7f697c6e1')
+source=("https://github.com/autodl-community/${_pkgname}/archive/community-v${pkgver}.tar.gz")
+md5sums=('6bc8c713949897b683a8811ed57ec40c')
package() {
- cd "$srcdir/"
+ cd "$srcdir/${pkgname}-v${pkgver}"
install -dm755 "$pkgdir/usr/share/$_pkgname"
@@ -41,4 +40,4 @@ package() {
install -Dm644 "README.md" "$pkgdir/usr/share/$_pkgname"
}
-# vim:ts=2 sw=2
+# vim:ts=2 sw=2 et: