summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVignesh Krishnamoorthy2016-10-29 09:04:25 +0200
committerVignesh Krishnamoorthy2016-10-29 09:27:51 +0200
commita944cdef965915856afd2baaff379cfe146351f0 (patch)
tree616af4f51276206ed65547c13cecb2d3ef0904a3
parent8c0b5c8329aecbe4089e4e6a33f33e65504d203d (diff)
downloadaur-a944cdef965915856afd2baaff379cfe146351f0.tar.gz
Fix version for autoenv.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04e7f1aa29b5..1358f75d1290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autoenv-git
pkgdesc = Directory based enviroments
- pkgver = 1.0.0.r102.c4bc3f5
- pkgrel = 2
+ pkgver = 0.2.0.r187.7eb70ec
+ pkgrel = 1
url = https://github.com/kennethreitz/autoenv
install = autoenv.install
arch = any
@@ -10,7 +10,7 @@ pkgbase = autoenv-git
depends = bash
optdepends = zsh: if you prefer zsh over bash
conflicts = autoenv
- source = git+https://github.com/kennethreitz/autoenv.git
+ source = autoenv-git::git+https://github.com/kennethreitz/autoenv.git
sha256sums = SKIP
pkgname = autoenv-git
diff --git a/PKGBUILD b/PKGBUILD
index c21753118308..32a90e23f240 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Directory based enviroments'
arch=('any')
url='https://github.com/kennethreitz/autoenv'
license=('custom')
-source=('git+https://github.com/kennethreitz/autoenv.git')
+source=("$pkgname"::'git+https://github.com/kennethreitz/autoenv.git')
sha256sums=('SKIP')
depends=('bash')
optdepends=('zsh: if you prefer zsh over bash')
@@ -16,9 +16,9 @@ makedepends=('git')
conflicts=('autoenv')
pkgver() {
- cd autoenv
+ cd "$pkgname"
set -o pipefail
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ # git describe --tags --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
# If there is a setup.py then pull the version tag from the file
if [ -f "setup.py" ]; then