summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lima2017-01-01 17:14:20 -0200
committerDaniel Lima2017-01-01 17:14:20 -0200
commit74667a6c15fc417365fc157ce4be48f7fb013439 (patch)
treeac014162cb36ee616f50a7d8695036d777c37cc7
downloadaur-74667a6c15fc417365fc157ce4be48f7fb013439.tar.gz
initial commit, v0.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--autoenv_fish.install9
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..229bb2c469a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jan 1 19:13:10 UTC 2017
+pkgbase = autoenv_fish
+ pkgdesc = Directory-based environments for fish shell
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/loopbit/autoenv_fish
+ install = autoenv_fish.install
+ arch = any
+ license = MIT
+ checkdepends = fish
+ source = https://github.com/loopbit/autoenv_fish/archive/0.2.0.tar.gz
+ sha512sums = ab31322a20bf7fb6915735193a4b9df3b755cb0d3fc5ca35ce371ffc26587125002b3bf4f1d5703fecc2f0c362476207f79576566638946da6ab974b195e27b7
+
+pkgname = autoenv_fish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..543daaa68a0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Lima <danielm@tinyhub.tk>
+
+pkgname=autoenv_fish
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Directory-based environments for fish shell'
+url="https://github.com/loopbit/${pkgname}"
+license=('MIT')
+checkdepends=('fish')
+source=(https://github.com/loopbit/${pkgname}/archive/${pkgver}.tar.gz)
+sha512sums=('ab31322a20bf7fb6915735193a4b9df3b755cb0d3fc5ca35ce371ffc26587125002b3bf4f1d5703fecc2f0c362476207f79576566638946da6ab974b195e27b7')
+arch=('any')
+install="${pkgname}.install"
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm644 activate.fish "${pkgdir}/usr/share/${pkgname}/activate.fish"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/autoenv_fish.install b/autoenv_fish.install
new file mode 100644
index 000000000000..3318beb7e967
--- /dev/null
+++ b/autoenv_fish.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Before using autoenv, you need to add it to your ~/.config/fish/config.fish"
+ echo
+ echo "echo 'source /usr/share/fish-autoenv/activate.fish' >> ~/.config/fish/config.fish"
+ echo
+ echo "You need to restart your shell afterwards."
+ echo
+ echo "Note: autoenv overrides cd. If you already do this, invoke autoenv_init in your custom cd after sourcing activate.fish."
+}