summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2017-04-17 09:28:14 +0200
committerMiguel Revilla2017-04-17 09:28:14 +0200
commit321eeeaa796eee95cebd24ab594f68f68af79a9f (patch)
tree97c7efdaa9e9abd2848e34e3e8653a608b03a4ed
downloadaur-321eeeaa796eee95cebd24ab594f68f68af79a9f.tar.gz
Initial release with version 1.4.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12f6de7a11ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = autofirma
+ pkgdesc = Spanish Government digital signature client
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://firmaelectronica.gob.es
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = EUPL
+ makedepends = binutils
+ depends = java-runtime
+ depends = nss
+ depends = firefox
+ source = http://estaticos.redsara.es/comunes/autofirma/currentversion/AutoFirma_Linux.zip
+ md5sums = ad388cfbea3ae49d073c528f120c1e2b
+
+pkgname = autofirma
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c89e3fd60e3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Miguel Revilla <yo at miguelrevilla dot com>
+
+pkgname=autofirma
+pkgver=1.4.2
+pkgrel=1
+pkgdesc='Spanish Government digital signature client'
+arch=('i686' 'x86_64')
+url='http://firmaelectronica.gob.es'
+license=('GPL' 'EUPL')
+depends=('java-runtime' 'nss' 'firefox')
+makedepends=('binutils')
+source=('http://estaticos.redsara.es/comunes/autofirma/currentversion/AutoFirma_Linux.zip')
+md5sums=('ad388cfbea3ae49d073c528f120c1e2b')
+
+prepare() {
+ ar -x AutoFirma_${pkgver}.deb
+ tar -xf data.tar.xz
+}
+
+package() {
+ mkdir -p "${pkgdir}"/usr/lib/firefox/defaults/pref/
+ cp -d --no-preserve=ownership etc/firefox/pref/AutoFirma.js "${pkgdir}"/usr/lib/firefox/defaults/pref/
+ cp -dr --no-preserve=ownership usr "${pkgdir}"/
+
+ rm "${pkgdir}"/usr/share/applications/afirma.desktop~
+ mkdir -p "${pkgdir}"/usr/share/licenses/autofirma/
+ ln -s /usr/share/doc/AutoFirma/copyright "${pkgdir}"/usr/share/licenses/autofirma/LICENSE
+
+ chmod 644 "${pkgdir}"/usr/share/applications/afirma.desktop
+ chmod 644 "${pkgdir}"/usr/share/doc/AutoFirma/copyright
+}