summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2021-04-14 16:58:43 +0200
committerÓscar García Amor2021-04-14 16:58:43 +0200
commit83e4b4043386e992ab87abab5ea98ccd5601db5c (patch)
treec7b859a50a0811b1d0c8485555e54682daa85a62
downloadaur-83e4b4043386e992ab87abab5ea98ccd5601db5c.tar.gz
Initial upload: autofirma-bin 1.6.5-1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD47
-rw-r--r--autofirma2
-rw-r--r--autofirma.desktop10
-rw-r--r--autofirma.js3
-rw-r--r--autofirma.svg1
7 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c9a683a395f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = autofirma-bin
+ pkgdesc = Cliente de firma electrónica ofrecido por la Administración Pública
+ pkgver = 1.6.5
+ pkgrel = 1
+ url = https://firmaelectronica.gob.es/
+ arch = any
+ license = GPL
+ license = EUPL
+ depends = java-runtime
+ source = autofirma-bin-1.6.5.zip::https://sede.xunta.gal/ficheiros/autofirma/AutoFirma_Linux.zip
+ source = autofirma
+ source = autofirma.desktop
+ source = autofirma.js
+ source = autofirma.svg
+ sha256sums = 28da745ea3084ba87b56eba31bc994e60872384c893c91f3e4aad3db4967d939
+ sha256sums = 17bb396857addaf763090b148301e05f70c20079182f7792aa60a038b7b5c635
+ sha256sums = 062cf72219e592e06218e47ea2a212d6517be66f0d4c58dcd03ef18d5c39300b
+ sha256sums = 428c5b7300dde7158a1a0918c8d2e8188f042dbc143d991c03f51d1c8a40efa4
+ sha256sums = f7e525586103db08a2a38ccefdef93cc02407728de8b214e53ae3dc0631bab75
+
+pkgname = autofirma-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0480dafe1e42
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!autofirma
+!autofirma.desktop
+!autofirma.js
+!autofirma.svg
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5490c9f1f257
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname=autofirma-bin
+pkgver=1.6.5
+pkgrel=1
+pkgdesc='Cliente de firma electrónica ofrecido por la Administración Pública'
+arch=('any')
+url='https://firmaelectronica.gob.es/'
+license=('GPL' 'EUPL')
+depends=('java-runtime')
+source=("${pkgname}-${pkgver}.zip::https://sede.xunta.gal/ficheiros/autofirma/AutoFirma_Linux.zip"
+ "autofirma"
+ "autofirma.desktop"
+ "autofirma.js"
+ "autofirma.svg")
+sha256sums=('28da745ea3084ba87b56eba31bc994e60872384c893c91f3e4aad3db4967d939'
+ '17bb396857addaf763090b148301e05f70c20079182f7792aa60a038b7b5c635'
+ '062cf72219e592e06218e47ea2a212d6517be66f0d4c58dcd03ef18d5c39300b'
+ '428c5b7300dde7158a1a0918c8d2e8188f042dbc143d991c03f51d1c8a40efa4'
+ 'f7e525586103db08a2a38ccefdef93cc02407728de8b214e53ae3dc0631bab75')
+
+prepare() {
+ # Extract debian package
+ bsdtar -O -xf AutoFirma*/*.deb data.tar.xz | bsdtar -C "${srcdir}" -xJf -
+
+ # Generate certificates
+ java -jar "usr/lib/AutoFirma/AutoFirmaConfigurador.jar"
+}
+
+package() {
+ install -Dm755 "autofirma" \
+ "${pkgdir}/usr/bin/autofirma"
+ install -Dm644 "autofirma.js" \
+ "${pkgdir}/usr/lib/firefox/defaults/pref/autofirma.js"
+ install -Dm644 "usr/lib/AutoFirma/AutoFirma.jar" \
+ "${pkgdir}/usr/share/java/autofirma/autofirma.jar"
+ install -Dm644 "usr/lib/AutoFirma/autofirma.pfx" \
+ "${pkgdir}/usr/share/java/autofirma/autofirma.pfx"
+ install -Dm644 "autofirma.svg" \
+ "${pkgdir}/usr/share/pixmaps/autofirma.svg"
+ install -Dm644 "autofirma.desktop" \
+ "${pkgdir}/usr/share/applications/autofirma.desktop"
+ install -Dm644 "usr/share/common-licenses/eupl-1.1.txt" \
+ "${pkgdir}/usr/share/licenses/autofirma/EUPL"
+ install -Dm644 "usr/lib/AutoFirma/AutoFirma_ROOT.cer" \
+ "${pkgdir}/usr/share/ca-certificates/trust-source/anchors/AutoFirma_ROOT.cer"
+}
diff --git a/autofirma b/autofirma
new file mode 100644
index 000000000000..131d04bb4a29
--- /dev/null
+++ b/autofirma
@@ -0,0 +1,2 @@
+#! /bin/sh
+java -jar /usr/share/java/autofirma/autofirma.jar $@
diff --git a/autofirma.desktop b/autofirma.desktop
new file mode 100644
index 000000000000..13e938a55ef3
--- /dev/null
+++ b/autofirma.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=AutoFirma
+Comment=Cliente @firma
+Icon=autofirma
+Exec=autofirma %U
+Categories=Utility;Java;
+StartupNotify=true
+StartupWMClass=autofirma
+MimeType=x-scheme-handler/afirma;
diff --git a/autofirma.js b/autofirma.js
new file mode 100644
index 000000000000..dbbdb899e411
--- /dev/null
+++ b/autofirma.js
@@ -0,0 +1,3 @@
+pref("network.protocol-handler.app.afirma","/usr/bin/autofirma");
+pref("network.protocol-handler.warn-external.afirma",false);
+pref("network.protocol-handler.external.afirma",true);
diff --git a/autofirma.svg b/autofirma.svg
new file mode 100644
index 000000000000..84b3fdbb40ad
--- /dev/null
+++ b/autofirma.svg
@@ -0,0 +1 @@
+<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 178.39 176.69"><path d="M89.235 168.45c-44.702 0-80.919-34.75-80.919-79.37S44.534 8.242 89.235 8.242c44.62 0 80.838 36.218 80.838 80.838s-36.218 79.37-80.838 79.37z" fill="#98141b" fill-rule="evenodd"/><path d="M89.195 43.67c22.32 0 36.72 2.809 43.272 8.28 6.552 5.544 9.864 17.784 9.864 36.576v4.104H89.195V80.607h38.88c-.648-10.368-2.664-16.92-6.049-19.729-4.031-3.456-15.047-5.184-32.832-5.184V43.67zm0 77.4c16.344 0 27-.937 31.824-2.88 4.896-1.944 7.272-6.049 7.272-12.456h14.04c0 11.447-3.313 18.863-9.864 22.248s-20.952 5.04-43.272 5.04zm-.072 11.952c-22.32 0-36.72-2.736-43.272-8.208s-9.792-17.641-9.792-36.36c0-18.792 3.24-30.96 9.792-36.504 6.552-5.472 20.952-8.28 43.272-8.28h.072v12.024h-.072c-17.784 0-28.8 1.728-32.976 5.184-3.24 2.809-5.256 9.36-5.904 19.729h38.952V92.63H50.027c.432 12.313 2.448 20.088 6.264 23.328 4.104 3.384 15.048 5.112 32.832 5.112h.072v11.952z" fill="#fff"/><path d="M89.239 176.19C40.218 176.19.5 138.081.5 89.148S40.218.498 89.239.498c48.932 0 88.65 39.718 88.65 88.65s-39.718 87.042-88.65 87.042z" fill="none" stroke="#98141b" stroke-miterlimit="10"/></svg>