summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Wagner2022-10-01 09:50:35 +0200
committerGeorg Wagner2022-10-01 09:50:35 +0200
commite95a077314b051e67e71011a75ab5b75e1c3ba8c (patch)
treec67dfeb0cbcafce292af1e1c2daba8e3facd2e6d
parentf7ab6ef6ac9e73e4789c0030ae90156a4fdf4002 (diff)
downloadaur-e95a077314b051e67e71011a75ab5b75e1c3ba8c.tar.gz
[different autogit project] v1.8.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
2 files changed, 34 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d385544cf49f..bf0bb440d496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = autogit
- pkgdesc = Define commands, using plugins, to execute across all your repositories.
- pkgver = 1.2.7
+ pkgdesc = Auto build, update, install PKGBUILDS from Github, Gitlab and AUR
+ pkgver = 1.8.0
pkgrel = 1
- url = https://github.com/fabiospampinato/autogit#readme
+ url = https://github.com/puxplaying/autogit
arch = any
- license = MIT
- makedepends = npm
- depends = nodejs
- noextract = autogit-1.2.7.tgz
- source = https://registry.npmjs.org/autogit/-/autogit-1.2.7.tgz
- sha256sums = e2e9c128b67b96cb16640e621d0f8a62fb1888abaf853dc06fa77c07f12dbf8c
+ license = GPL3
+ makedepends = git
+ depends = pacman
+ depends = sudo
+ depends = bash
+ depends = curl
+ depends = fzf
+ optdepends = manjaro-tools-pkg: Needed for Manjaro clean chroot package building
+ optdepends = manjaro-chrootbuild: Needed for Manjaro clean chroot package building
+ backup = etc/autogit/autogit.conf
+ source = autogit-1.8.0.tar.gz::https://github.com/puxplaying/autogit/archive/1.8.0.tar.gz
+ sha256sums = 3c2879eb8cc859a6b71acbb933483c4a647685086cb5c51cc89fa99bf8fb8166
pkgname = autogit
-
diff --git a/PKGBUILD b/PKGBUILD
index 7d3d8eb6573d..7517304d2201 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+# Maintainer: Georg Wagner <puxplaying_at_gmail_dot_com>
+
pkgname=autogit
-pkgver=1.2.7
+pkgver=1.8.0
pkgrel=1
-pkgdesc="Define commands, using plugins, to execute across all your repositories."
-arch=(any)
-url="https://github.com/fabiospampinato/autogit#readme"
-license=('MIT')
-depends=('nodejs')
-makedepends=('npm')
-optdepends=()
-source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
-noextract=($pkgname-$pkgver.tgz)
+pkgdesc="Auto build, update, install PKGBUILDS from Github, Gitlab and AUR"
+arch=('any')
+url="https://github.com/puxplaying/autogit"
+license=('GPL3')
+depends=('pacman' 'sudo' 'bash' 'curl' 'fzf')
+makedepends=('git')
+optdepends=('manjaro-tools-pkg: Needed for Manjaro clean chroot package building'
+ 'manjaro-chrootbuild: Needed for Manjaro clean chroot package building')
+backup=("etc/$pkgname/$pkgname.conf")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('3c2879eb8cc859a6b71acbb933483c4a647685086cb5c51cc89fa99bf8fb8166')
-package() {
- cd $srcdir
- local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p $_npmdir
- cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
- find "${pkgdir}"/usr -name package.json -exec sed -i '/"_where"/d' '{}' '+'
- find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+package () {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin/"
+ install -Dm644 "$pkgname.conf" -t "$pkgdir/etc/$pkgname/"
+ cp -r reponames "$pkgdir/etc/$pkgname/"
}
-
-sha256sums=('e2e9c128b67b96cb16640e621d0f8a62fb1888abaf853dc06fa77c07f12dbf8c')