summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2015-06-09 12:20:01 +0200
committerjakob2015-06-09 12:20:01 +0200
commit70df06fa57c11ee76f1e587cd99d3b25817d1e11 (patch)
tree8774ffb69b06abe238f1bfd7d47c2277dcd854f0
downloadaur-70df06fa57c11ee76f1e587cd99d3b25817d1e11.tar.gz
pkgver 0.3-1
-rw-r--r--.Changelog8
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
3 files changed, 58 insertions, 0 deletions
diff --git a/.Changelog b/.Changelog
new file mode 100644
index 000000000000..7f206614c79f
--- /dev/null
+++ b/.Changelog
@@ -0,0 +1,8 @@
+2015-04-24 jakob <grandchild@gmx.net>
+
+ * 0.1-1 :
+ Initial package.
+
+ * 0.2-1 :
+ Add /etc/autohidewibox.conf.
+ \ No newline at end of file
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50ba96302b24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Tue May 5 14:02:50 UTC 2015
+pkgbase = autohidewibox
+ pkgdesc = Show awesome WM wibox only on ModKey press
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/grandchild/autohidewibox
+ changelog = .Changelog
+ arch = i686
+ arch = x86_64
+ depends = python
+ depends = xorg-xinput
+ provides = autohidewibox
+ conflicts = autohidewibox
+ source = https://raw.githubusercontent.com/grandchild/autohidewibox/0.3/autohidewibox.py
+ source = https://raw.githubusercontent.com/grandchild/autohidewibox/0.3/autohidewibox.conf
+ sha1sums = d35b5a86ccd8eaf38e4e9a6cb0facc6368f167f3
+ sha1sums = 413629a2f3b83d18b807954429fbf7348136e753
+
+pkgname = autohidewibox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0428281db5e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: jakob <grandchild@gmx.net>
+
+pkgname=autohidewibox
+pkgver=0.3
+pkgrel=1
+pkgdesc="Show awesome WM wibox only on ModKey press"
+url=https://github.com/grandchild/${pkgname}
+#install=${pkgname}.install
+changelog=.Changelog
+arch=('i686' 'x86_64')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+depends=('python' 'xorg-xinput')
+source=(
+ "https://raw.githubusercontent.com/grandchild/${pkgname}/${pkgver}/${pkgname}.py"
+ "https://raw.githubusercontent.com/grandchild/${pkgname}/${pkgver}/${pkgname}.conf"
+)
+sha1sums=(
+ 'd35b5a86ccd8eaf38e4e9a6cb0facc6368f167f3'
+ '413629a2f3b83d18b807954429fbf7348136e753'
+)
+
+package() {
+ cd $srcdir/
+ install -d $pkgdir/usr/bin
+ install -Dm755 ${pkgname}.py $pkgdir/usr/bin/
+ install -d $pkgdir/etc
+ install -Dm644 ${pkgname}.conf $pkgdir/etc/
+}