summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkngfr2019-07-18 21:24:28 +0200
committerkngfr2019-07-18 21:24:28 +0200
commit17c59892d9a7b794f4b8b14ce5815cfd2dd88cb7 (patch)
treef3482181e85253fd6fbf94514c2e7cfc6110a552
downloadaur-17c59892d9a7b794f4b8b14ce5815cfd2dd88cb7.tar.gz
adding working PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD62
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe4f5201096c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = autoi3
+ pkgdesc = A couple of helper scripts for i3
+ pkgver = r7.f6cac83
+ pkgrel = 1
+ url = https://gitlab.com/lejs/autoi3
+ arch = any
+ license = MIT
+ depends = python3
+ source = git+https://gitlab.com/lejs/autoi3
+ sha256sums = SKIP
+
+pkgname = autoi3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..abd7a5a63474
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.xz
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36bc9c83ffa5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: <kngfr> 9bcfbc1ca230857ba09584697f20708a@kngfr.de
+pkgname=autoi3
+pkgver=r7.f6cac83
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgrel=1
+epoch=
+pkgdesc="A couple of helper scripts for i3"
+arch=('any')
+url="https://gitlab.com/lejs/autoi3"
+license=('MIT')
+groups=()
+depends=('python3')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://gitlab.com/lejs/autoi3")
+sha256sums=('SKIP')
+noextract=()
+
+#prepare() {
+# cd "$srcdir/$pkgname-$pkgver"
+#
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+
+#build() {
+# cd "$srcdir/$pkgname-$pkgver"
+#
+# ./configure --prefix=/usr
+# make
+#}
+
+#check() {
+# cd "$srcdir/$pkgname-$pkgver"
+#
+# make -k check
+#}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ # actual program files
+ install -D -t "$pkgdir"/usr/share/"$pkgname" *.py
+
+ # documentation
+ install -D -t "$pkgdir"/usr/share/doc/"$pkgname"/ README.md
+
+ # license
+ install -D -t "$pkgdir"/usr/share/licenses/"$pkgname" LICENSE
+}
+
+# vim:set ts=2 sw=2 et: