summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWojciech Szymecki2016-01-11 11:09:08 +0100
committerWojciech Szymecki2016-01-11 11:09:08 +0100
commit7f25a773cfdb289247e9aaba6323402690753744 (patch)
treee45040a3d1774ddb3d72ad9ee1aeecc0fd480451
downloadaur-7f25a773cfdb289247e9aaba6323402690753744.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e12e6840c3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jan 11 10:06:27 UTC 2016
+pkgbase = autojsoncxx-git
+ pkgver = 0.3.0.r42.gf6b171a
+ pkgrel = 1
+ url = https://netheril96.github.io/autojsoncxx/
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = python
+ depends = rapidjson
+ optdepends = python-parsimonious: for type checks
+ optdepends = boost: to use boost types
+ source = autojsoncxx-git::git+https://github.com/netheril96/autojsoncxx.git
+ md5sums = SKIP
+
+pkgname = autojsoncxx-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7e95ddc40e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Wojciech Szymecki <w.szymecki-at-g;mail-com>
+pkgname="autojsoncxx-git"
+pkgver=0.3.0.r42.gf6b171a
+pkgrel=1
+arch=('any')
+url="https://netheril96.github.io/autojsoncxx/"
+license=('MIT')
+depends=('python' 'rapidjson')
+makedepends=('cmake' 'git')
+optdepends=('python-parsimonious: for type checks'
+ 'boost: to use boost types')
+source=("${pkgname}::git+https://github.com/netheril96/autojsoncxx.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname}"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "${pkgname}"
+ cmake -G 'Unix Makefiles' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+}
+
+package() {
+ cd "${pkgname}"
+
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}