summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2014-03-10 15:35:05 +0100
committerCedric Girard2014-03-10 15:36:59 +0100
commit78ebd0c1e742d1cf1ac28be9a0728c1004481579 (patch)
tree94b6d1bd615ae9d02e5e33c286e99c3c1ad742af
downloadaur-78ebd0c1e742d1cf1ac28be9a0728c1004481579.tar.gz
adopted and updated autojump-git PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--install6
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5398b452d0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = autojump-git
+ pkgdesc = A faster way to navigate your filesystem from the command line
+ pkgver = release.v21.6.9.149.g72313db
+ pkgrel = 1
+ url = http://github.com/joelthelion/autojump
+ install = install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ depends = python
+ provides = autojump
+ conflicts = autojump
+ source = git+https://github.com/joelthelion/autojump.git
+ md5sums = SKIP
+
+pkgname = autojump-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d88870b5234e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: Jason Axelson <jason.axelsonATgmail.com>
+# Contributor: Sean Escriva <sean.escrivaATgmail.com>
+# Contributor: William Ting <william.h.tingATgmail.com>
+
+pkgname=autojump-git
+pkgver=release.v21.6.9.149.g72313db
+pkgrel=1
+pkgdesc="A faster way to navigate your filesystem from the command line"
+arch=(any)
+url="http://github.com/joelthelion/autojump"
+license=('GPL3')
+depends=('bash' 'python')
+makedepends=('git')
+conflicts=('autojump')
+provides=('autojump')
+replaces=()
+backup=()
+source=('git+https://github.com/joelthelion/autojump.git')
+md5sums=('SKIP')
+install='install'
+
+_gitname="autojump"
+
+pkgver() {
+ cd ${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd ${_gitname}
+ sed -i 's$#!/usr/bin/env python$#!/usr/bin/env python2$' bin/autojump bin/*.py
+}
+
+package() {
+ cd ${_gitname}
+ /usr/bin/env python2 ./install.py --prefix 'usr/' --destdir "${pkgdir}" --zshshare 'usr/share/zsh/site-functions'
+}
+
+
+# vim:set ts=4 sw=4 et:
diff --git a/install b/install
new file mode 100644
index 000000000000..fd8ec2127835
--- /dev/null
+++ b/install
@@ -0,0 +1,6 @@
+function post_install {
+ echo " > Please add the line to ~/.bashrc :"
+ echo " > [[ -s /etc/profile.d/autojump.bash ]] && . /etc/profile.d/autojump.bash"
+ echo " > Or substitute ~/.zshrc and /etc/profile.d/autojump.zsh"
+ echo " > You need to run 'source ~/.bashrc' before you can start using autojump."
+}