summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2019-11-25 17:05:43 +0100
committerCedric Girard2019-11-25 17:07:37 +0100
commite37a9676cc63e597dfabd8f51f038452802ac2b3 (patch)
treea9b05e3e18c3dce4ea5089cb3a93583a560daf74
parentbdffb1e02ce0aa8c24a8d129d3b85b7ce7f1d087 (diff)
downloadaur-e37a9676cc63e597dfabd8f51f038452802ac2b3.tar.gz
upgpkg: autojump-git 22.5.3.r0.g06e082c-2
import corrections from autojump PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4f0e09840c8..1c249821566a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autojump-git
pkgdesc = A faster way to navigate your filesystem from the command line
pkgver = 22.5.3.r0.g06e082c
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/wting/autojump
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index e75141ecd649..ed795f6f6720 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=autojump-git
pkgver=22.5.3.r0.g06e082c
-pkgrel=1
+pkgrel=2
pkgdesc="A faster way to navigate your filesystem from the command line"
arch=(any)
url="http://github.com/wting/autojump"
@@ -14,8 +14,6 @@ depends=('python')
makedepends=('git')
conflicts=('autojump')
provides=('autojump')
-replaces=()
-backup=()
source=('git+https://github.com/wting/autojump.git')
md5sums=('SKIP')
@@ -41,9 +39,21 @@ package() {
"${pkgdir}"/etc/profile.d/$i
done
- #https://github.com/joelthelion/autojump/pull/339
+ # FS#60929
+ install -d "${pkgdir}/usr/lib/$_python/site-packages"
+ mv ${pkgdir}/usr/bin/*.py "${pkgdir}/usr/lib/$_python/site-packages"
+ python -m compileall -d /usr/lib "${pkgdir}/usr/lib"
+ python -O -m compileall -d /usr/lib "${pkgdir}/usr/lib"
+
+ # FS#49601
+ install -d "${pkgdir}"/usr/share/fish/completions
+ mv "${pkgdir}"/etc/profile.d/$_gitname.fish "${pkgdir}"/usr/share/fish/completions
+
+ # https://github.com/joelthelion/autojump/pull/339
sed -i "s!/usr/local/!/usr/!g" "${pkgdir}"/etc/profile.d/$_gitname.sh
- #FS#43762
+ sed -i "s!/build/${pkgname}/pkg/${pkgname}/!/!g" "${pkgdir}"/etc/profile.d/$_gitname.sh
+
+ # FS#43762
sed -i '27,31d' "${pkgdir}"/etc/profile.d/$_gitname.sh
}