summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian LaVine2023-01-03 14:28:56 -0500
committerSebastian LaVine2023-01-03 14:29:54 -0500
commit3ad58fd2ff7d4082f97fd828a77e4267696058c7 (patch)
treea7ad622ced299ed36a529b36b6f269bc07a7019a
parent9278bcf6a6abac854b6b828021da374976756148 (diff)
downloadaur-3ad58fd2ff7d4082f97fd828a77e4267696058c7.tar.gz
Move binaries to arch-specific source arrays
This corrects an issue with a failed validity check on non-x86_64 architectures.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 15 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f48c3378b850..a6ba01ff7862 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autojump-rs
pkgdesc = A faster way to navigate your filesystem from the command line (in Rust)
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xen0n/autojump-rs
arch = x86_64
arch = i686
@@ -10,17 +10,13 @@ pkgbase = autojump-rs
makedepends = python>=3.8
provides = autojump
conflicts = autojump
- source = autojump-rs-0.5.1.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/0.5.1/autojump-x86_64-unknown-linux-musl.tar.gz
source = autojump-22.5.3.tar.gz::https://github.com/wting/autojump/archive/release-v22.5.3.tar.gz
- md5sums = 1cabb0c3551c865f2da81a2e2af48423
md5sums = 29f1a7df736814c747645703bf00ce48
+ source_x86_64 = autojump-rs-0.5.1.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/0.5.1/autojump-x86_64-unknown-linux-musl.tar.gz
+ md5sums_x86_64 = 1cabb0c3551c865f2da81a2e2af48423
source_i686 = autojump-rs-0.5.1.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/0.5.1/autojump-x86_64-unknown-linux-musl.tar.gz
- source_i686 = autojump-22.5.3.tar.gz::https://github.com/wting/autojump/archive/release-v22.5.3.tar.gz
md5sums_i686 = 2bb1476558d240416629c41af39a44c3
- md5sums_i686 = 29f1a7df736814c747645703bf00ce48
source_aarch64 = autojump-rs-0.5.1.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/0.5.1/autojump-x86_64-unknown-linux-musl.tar.gz
- source_aarch64 = autojump-22.5.3.tar.gz::https://github.com/wting/autojump/archive/release-v22.5.3.tar.gz
md5sums_aarch64 = c20e6afc93e038cae8fe13179fa8d51c
- md5sums_aarch64 = 29f1a7df736814c747645703bf00ce48
pkgname = autojump-rs
diff --git a/PKGBUILD b/PKGBUILD
index ad78efd9da85..9b59c35fc6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jon Gjengset <jon@thesquareplanet.com>
pkgname=autojump-rs
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A faster way to navigate your filesystem from the command line (in Rust)"
arch=('x86_64' 'i686' 'aarch64')
url="https://github.com/xen0n/autojump-rs"
@@ -14,27 +14,19 @@ makedepends=('python>=3.8')
options=()
install=
_autojump_version='22.5.3'
-source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/${pkgver}/autojump-${CARCH}-unknown-linux-musl.tar.gz"
- "autojump-${_autojump_version}.tar.gz::https://github.com/wting/autojump/archive/release-v${_autojump_version}.tar.gz"
-)
-md5sums=('1cabb0c3551c865f2da81a2e2af48423'
- '29f1a7df736814c747645703bf00ce48')
-# alt arches
-source_aarch64=(
- "$pkgname-$pkgver.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/${pkgver}/autojump-${CARCH}-unknown-linux-musl.tar.gz"
- "autojump-${_autojump_version}.tar.gz::https://github.com/wting/autojump/archive/release-v${_autojump_version}.tar.gz"
-)
-md5sums_aarch64=('c20e6afc93e038cae8fe13179fa8d51c'
- '29f1a7df736814c747645703bf00ce48')
+source=("autojump-${_autojump_version}.tar.gz::https://github.com/wting/autojump/archive/release-v${_autojump_version}.tar.gz")
+md5sums=('29f1a7df736814c747645703bf00ce48')
-source_i686=(
- "$pkgname-$pkgver.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/${pkgver}/autojump-${CARCH}-unknown-linux-musl.tar.gz"
- "autojump-${_autojump_version}.tar.gz::https://github.com/wting/autojump/archive/release-v${_autojump_version}.tar.gz"
-)
-md5sums_i686=('2bb1476558d240416629c41af39a44c3'
- '29f1a7df736814c747645703bf00ce48')
+# architecture-specific binaries
+source_x86_64=("$pkgname-$pkgver.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/${pkgver}/autojump-${CARCH}-unknown-linux-musl.tar.gz")
+md5sums_x86_64=('1cabb0c3551c865f2da81a2e2af48423')
+
+source_aarch64=("$pkgname-$pkgver.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/${pkgver}/autojump-${CARCH}-unknown-linux-musl.tar.gz")
+md5sums_aarch64=('c20e6afc93e038cae8fe13179fa8d51c')
+
+source_i686=("$pkgname-$pkgver.tar.gz::https://github.com/xen0n/autojump-rs/releases/download/${pkgver}/autojump-${CARCH}-unknown-linux-musl.tar.gz")
+md5sums_i686=('2bb1476558d240416629c41af39a44c3')
prepare() {
cd "autojump-release-v${_autojump_version}"