summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-07 11:34:52 -0600
committerMark Wagie2021-04-07 11:34:52 -0600
commit1b2b152965598b98923fce6dba48580198df682e (patch)
tree28d4d8ee3c773ef746afc305e56c4a8a01f41399
parentf71778209536ab5ca67f65d19dbd0b49cb7eecda (diff)
downloadaur-1b2b152965598b98923fce6dba48580198df682e.tar.gz
add patch
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--autokey.patch25
4 files changed, 41 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dbedb4b5012..5b9dca49aac3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = autokey
pkgver = 0.95.10
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/autokey/autokey
arch = i686
arch = x86_64
@@ -8,7 +8,9 @@ pkgbase = autokey
makedepends = python-setuptools
makedepends = python-pyqt5
source = autokey-0.95.10.tar.gz::https://github.com/autokey/autokey/archive/v0.95.10.tar.gz
+ source = autokey.patch
sha256sums = e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d
+ sha256sums = 9959643c90b51f4734da70afecb891ad4671ab9f277cc3abf9506421a98acb98
pkgname = autokey-common
pkgdesc = A desktop automation utility for Linux and X11 - common data
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..b891923403d7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!autokey.patch
diff --git a/PKGBUILD b/PKGBUILD
index ce2933fc2760..c789abb9008f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,22 @@
pkgname=('autokey-common' 'autokey-gtk' 'autokey-qt')
pkgbase=autokey
pkgver=0.95.10
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
url="https://github.com/autokey/autokey"
license=('GPL3')
makedepends=('python-setuptools' 'python-pyqt5')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/autokey/autokey/archive/v$pkgver.tar.gz")
-sha256sums=('e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/autokey/autokey/archive/v$pkgver.tar.gz"
+ "$pkgbase.patch")
+sha256sums=('e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d'
+ '9959643c90b51f4734da70afecb891ad4671ab9f277cc3abf9506421a98acb98')
+
+prepare() {
+
+ # Phrases show up wrong on Firefox and Thunderbird
+ # https://code.google.com/archive/p/autokey/issues/278
+ patch -Np1 -i "$srcdir/$pkgbase.patch"
+}
build() {
cd "$pkgbase-$pkgver"
diff --git a/autokey.patch b/autokey.patch
new file mode 100644
index 000000000000..3c0c5b4d80a8
--- /dev/null
+++ b/autokey.patch
@@ -0,0 +1,25 @@
+--- src/autokey-0.95.10/lib/autokey/interface.py
++++ src/autokey-0.95.10/lib/autokey/interface.py
+@@ -751,6 +751,10 @@ class XInterfaceBase(threading.Thread):
+
+ focus = self.localDisplay.get_input_focus().focus
+
++ # Patch from https://code.google.com/archive/p/autokey/issues/278
++ self.localDisplay.flush()
++ time.sleep(0.01)
++
+ for char in string:
+ try:
+ keyCodeList = self.localDisplay.keysym_to_keycodes(ord(char))
+@@ -796,6 +800,11 @@ class XInterfaceBase(threading.Thread):
+ self.__enqueue(self.__sendKey, keyName)
+
+ def __sendKey(self, keyName):
++
++ # Patch from https://code.google.com/archive/p/autokey/issues/278
++ self.localDisplay.flush()
++ time.sleep(0.01)
++
+ logger.debug("Send special key: [%r]", keyName)
+ self.__sendKeyCode(self.__lookupKeyCode(keyName))
+