summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnaud Dovi2021-04-27 21:21:51 +0200
committerArnaud Dovi2021-04-27 21:21:51 +0200
commitb489ef00af330d396f798849e61fec80dff61209 (patch)
tree98bec947bfd52fe100485c6c6235ca64b42b69ca
downloadaur-b489ef00af330d396f798849e61fec80dff61209.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD82
2 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98d22ec9c620
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = autokey-git
+ pkgdesc = A desktop automation utility for Linux and X11 - GTK & Qt frontends
+ pkgver = 0.95.10.r18.4b87b32
+ pkgrel = 1
+ url = https://github.com/autokey/autokey
+ arch = x86_64
+ license = GPL3
+ makedepends = python-pyqt5
+ makedepends = python-setuptools
+ depends = gtksourceview3
+ depends = kdialog
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = python
+ depends = python-gobject
+ depends = python-pyqt5
+ depends = python-qscintilla-qt5
+ depends = qt5-svg
+ depends = zenity
+ optdepends = python-atspi
+ optdepends = qt-at-spi
+ provides = autokey
+ provides = autokey-gtk
+ provides = autokey-qt
+ conflicts = autokey-common
+ conflicts = autokey-gtk
+ conflicts = autokey-qt
+ source = git+https://github.com/autokey/autokey
+ sha512sums = SKIP
+
+pkgname = autokey-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71a7257e852a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: Arnaud Dovi <mr.dovi@gmail.com>
+
+pkgname=('autokey-git')
+pkgver=0.95.10.r18.4b87b32
+pkgrel=1
+pkgdesc='A desktop automation utility for Linux and X11 - GTK & Qt frontends'
+arch=('x86_64')
+url='https://github.com/autokey/autokey'
+license=('GPL3')
+provides=(
+ 'autokey'
+ 'autokey-gtk'
+ 'autokey-qt'
+)
+conflicts=(
+ 'autokey-common'
+ 'autokey-gtk'
+ 'autokey-qt'
+)
+depends=(
+ 'gtksourceview3'
+ 'kdialog'
+ 'libappindicator-gtk3'
+ 'libnotify'
+ 'python'
+ 'python-gobject'
+ 'python-pyqt5'
+ 'python-qscintilla-qt5'
+ 'qt5-svg'
+ 'zenity'
+)
+makedepends=(
+ 'python-pyqt5'
+ 'python-setuptools'
+)
+optdepends=(
+ 'python-atspi'
+ 'qt-at-spi'
+)
+source=(
+ "git+https://github.com/autokey/autokey"
+)
+sha512sums=(
+ 'SKIP'
+)
+pkgname2="${pkgname/-git/}"
+stop='\e[m'
+color="\e[33m"
+bold='\e[1m'
+prefix=" ${bold}${color}==>$stop "
+
+
+
+pkgver() {
+ cd "$pkgname2" || return
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$pkgname2" || return
+}
+
+build() {
+ cd "$pkgname2" || return
+ echo -e "${prefix}Building AutoKey"
+
+ python setup.py build
+ # remove shebang from python libraries
+ for lib in $(find lib/autokey/ -name "*.py"); do
+ sed '/\/usr\/bin\/env/d' $lib > $lib.new &&
+ touch -r $lib $lib.new &&
+ mv $lib.new $lib
+ done
+}
+
+package() {
+ cd "$pkgname2" || return
+ echo -e "${prefix}Packaging AutoKey"
+
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip build
+}