summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKavya2020-05-04 11:09:26 +0530
committerKavya2020-05-04 11:09:26 +0530
commit8acdb925379391ab4da97d840c2284f00b21f7f9 (patch)
tree2bc4193b493c98cf46317fb5e387295b4c454d57
downloadaur-autokey-patched.tar.gz
Initial commit, added patch
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD35
-rw-r--r--autokey.patch25
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7e51d44441a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = autokey-patched
+ pkgdesc = AutoKey, a desktop automation utility for Linux and X11, updated to run on Python 3, with additional patch from here to fix issues in Firefox https://code.google.com/archive/p/autokey/issues/278
+ pkgver = 0.95.10
+ pkgrel = 1
+ url = https://github.com/autokey/autokey
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = wmctrl
+ depends = python-dbus
+ depends = python-pyinotify
+ depends = zenity
+ depends = xautomation
+ depends = imagemagick
+ depends = xorg-xwd
+ depends = python-xlib
+ depends = python-setuptools
+ depends = python-gobject
+ depends = gtksourceview3
+ depends = libnotify
+ depends = libappindicator-gtk3
+ depends = gtk-update-icon-cache
+ optdepends = kdialog: for Qt interface
+ optdepends = python-pyqt5: for Qt interface
+ optdepends = python-qscintilla-qt5: for Qt interface
+ optdepends = qt5-svg: for Qt interface
+ optdepends = qt-at-spi: to work with KDE/Qt applications
+ optdepends = python-atspi: for ATSPI in Gtk interface
+ conflicts = autokey
+ replaces = autokey-py3,
+ replaces = autokey
+ source = autokey-patched-0.95.10.tar.gz::https://github.com/autokey-py3/autokey/archive/v0.95.10.tar.gz
+ sha256sums = e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d
+
+pkgname = autokey-patched
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a98d01e5f5cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kavya Gokul <hello@properlypurple.com>
+# Derived from PKGBUILD here https://aur.archlinux.org/packages/autokey/
+# Contributor: Dmitry Kharitonov <darksab0r@gmail.com>
+# Contributor: Dave Blair <mail@dave-blair.de>
+
+pkgname=autokey-patched
+pkgver=0.95.10
+pkgrel=1
+pkgdesc="AutoKey, a desktop automation utility for Linux and X11, updated to run on Python 3, with additional patch from here to fix issues in Firefox https://code.google.com/archive/p/autokey/issues/278"
+arch=('i686' 'x86_64')
+url="https://github.com/autokey/autokey"
+depends=('python' 'wmctrl' 'python-dbus' 'python-pyinotify'
+ 'zenity' 'xautomation' 'imagemagick' 'xorg-xwd' 'python-xlib' 'python-setuptools'
+ 'python-gobject' 'gtksourceview3' 'libnotify'
+ 'libappindicator-gtk3' 'gtk-update-icon-cache')
+optdepends=('kdialog: for Qt interface'
+ 'python-pyqt5: for Qt interface'
+ 'python-qscintilla-qt5: for Qt interface'
+ 'qt5-svg: for Qt interface'
+ 'qt-at-spi: to work with KDE/Qt applications'
+ 'python-atspi: for ATSPI in Gtk interface')
+replaces=('autokey-py3' 'autokey')
+conflicts=('autokey')
+license=('GPL3')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/autokey-py3/autokey/archive/v${pkgver}.tar.gz")
+sha256sums=('e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d')
+
+prepare() {
+ patch -p1 -i "../autokey.patch"
+}
+
+package() {
+ cd "$srcdir/autokey-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
diff --git a/autokey.patch b/autokey.patch
new file mode 100644
index 000000000000..3c0c5b4d80a8
--- /dev/null
+++ b/autokey.patch
@@ -0,0 +1,25 @@
+--- src/autokey-0.95.10/lib/autokey/interface.py
++++ src/autokey-0.95.10/lib/autokey/interface.py
+@@ -751,6 +751,10 @@ class XInterfaceBase(threading.Thread):
+
+ focus = self.localDisplay.get_input_focus().focus
+
++ # Patch from https://code.google.com/archive/p/autokey/issues/278
++ self.localDisplay.flush()
++ time.sleep(0.01)
++
+ for char in string:
+ try:
+ keyCodeList = self.localDisplay.keysym_to_keycodes(ord(char))
+@@ -796,6 +800,11 @@ class XInterfaceBase(threading.Thread):
+ self.__enqueue(self.__sendKey, keyName)
+
+ def __sendKey(self, keyName):
++
++ # Patch from https://code.google.com/archive/p/autokey/issues/278
++ self.localDisplay.flush()
++ time.sleep(0.01)
++
+ logger.debug("Send special key: [%r]", keyName)
+ self.__sendKeyCode(self.__lookupKeyCode(keyName))
+