summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2018-08-08 20:25:26 +0500
committerDmitry Kharitonov2018-08-08 20:25:26 +0500
commita8e273f37edf7a7f0db2b3e4b36331065a4bdcde (patch)
tree9797ab3bd10ada6427efc0436285f6238b385828
parent18ee40ee6c59a5ddab52d18131039870669bf536 (diff)
downloadaur-a8e273f37edf7a7f0db2b3e4b36331065a4bdcde.tar.gz
Added patch: pyatspi is now optional dep again
Use python-atspi-git package if you need ATSPI on Gtk interface, the error messages are silenced now
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--atspi.patch11
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d858ef0579c..49b792ab7024 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autokey-py3
pkgdesc = Python 3 port of AutoKey, a desktop automation utility for Linux and X11 with new features.
pkgver = 0.95.2
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/autokey/autokey
arch = any
license = GPL3
@@ -22,17 +22,19 @@ pkgbase = autokey-py3
depends = libnotify
depends = libappindicator-gtk3
depends = gtk-update-icon-cache
- depends = python-atspi-git
optdepends = kdialog: for Qt interface
optdepends = python-pyqt5: for Qt interface
optdepends = python-qscintilla-qt5: for Qt interface
optdepends = qt-at-spi: to work with KDE/Qt applications
+ optdepends = python-atspi-git: temporarily required for ATSPI in Gtk interface
conflicts = autokey
conflicts = autokey-gtk
conflicts = autokey-data
source = autokey-py3-0.95.2.tar.gz::https://github.com/autokey-py3/autokey/archive/v0.95.2.tar.gz
+ source = atspi.patch
source = requires.patch
sha256sums = 2354d0ea45b6d4dafdb9da9b9d046e204616f2612c8c21ac36550e88f362b499
+ sha256sums = 1e5014aec1a8a1b6bdb292e6c1c8133e885bfe9b5c04691e786393776f30b8fd
sha256sums = 4e33374c4eff96573ce92fda5e8263c8a610c9ba9fdce98046a0a3a05ac9a478
pkgname = autokey-py3
diff --git a/PKGBUILD b/PKGBUILD
index 7e7dc1ea5b87..8e3f0a988eec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,33 @@
pkgname=autokey-py3
pkgver=0.95.2
-pkgrel=4
+pkgrel=5
pkgdesc="Python 3 port of AutoKey, a desktop automation utility for Linux and X11 with new features."
url="https://github.com/autokey/autokey"
depends=('python' 'wmctrl' 'hicolor-icon-theme' 'python-dbus' 'python-pyinotify'
'zenity' 'xautomation' 'imagemagick' 'xorg-xwd' 'python-xlib' 'python-six'
'python-gobject' 'gtksourceview3' 'libnotify' 'libappindicator-gtk3'
- 'gtk-update-icon-cache' 'python-atspi-git')
+ 'gtk-update-icon-cache')
makedepends=('python-setuptools')
optdepends=('kdialog: for Qt interface'
'python-pyqt5: for Qt interface'
'python-qscintilla-qt5: for Qt interface'
- 'qt-at-spi: to work with KDE/Qt applications')
+ 'qt-at-spi: to work with KDE/Qt applications'
+ 'python-atspi-git: temporarily required for ATSPI in Gtk interface')
conflicts=('autokey' 'autokey-gtk' 'autokey-data')
license=('GPL3')
arch=('any')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/autokey-py3/autokey/archive/v${pkgver}.tar.gz"
+ "atspi.patch"
"requires.patch")
sha256sums=('2354d0ea45b6d4dafdb9da9b9d046e204616f2612c8c21ac36550e88f362b499'
+ '1e5014aec1a8a1b6bdb292e6c1c8133e885bfe9b5c04691e786393776f30b8fd'
'4e33374c4eff96573ce92fda5e8263c8a610c9ba9fdce98046a0a3a05ac9a478')
prepare() {
cd "$srcdir/autokey-${pkgver}"
patch -Np1 -i ../requires.patch
+ patch -Np1 -i ../atspi.patch
}
package() {
diff --git a/atspi.patch b/atspi.patch
new file mode 100644
index 000000000000..5d3c1796801a
--- /dev/null
+++ b/atspi.patch
@@ -0,0 +1,11 @@
+--- /lib/autokey/interface.py
++++ /lib/autokey/interface.py
+@@ -57,6 +57,8 @@
+ HAS_ATSPI = False
+ except ValueError:
+ HAS_ATSPI = False
++ except SyntaxError: # pyatspi 2.26 fails when used with Python 3.7
++ HAS_ATSPI = False
+
+ from Xlib import X, XK, display, error
+ try: