summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2017-01-06 23:09:32 +0500
committerDmitry Kharitonov2017-01-06 23:09:32 +0500
commitc646f2be70922a423cce24f015ace7b501cb3503 (patch)
treec78f281de63e2a21fc6763a3891b2c4ed504c5a0
parent59c2ca4bdc00f6d2f113bff9df7c84a06c21d8f5 (diff)
downloadaur-c646f2be70922a423cce24f015ace7b501cb3503.tar.gz
Updated to 0.93.7; GTK deps are now mandatory, not optional
Added libappindicator-gtk3 dep; mentioned that autokey-qt is now deprecated because KDE upstream kind of dropped support for pykde4 and kdebindings-python were removed from Arch repos; removed kde4 patch because it was fixed upstream; changed source links to GitHub.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
-rw-r--r--setup-kde4-fix.patch11
3 files changed, 22 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac486c3fb1bb..fb96f4111e54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Sep 10 21:00:28 UTC 2016
+# Fri Jan 6 18:09:15 UTC 2017
pkgbase = autokey-py3
pkgdesc = Python 3 port of AutoKey, a desktop automation utility for Linux and X11 with new features.
- pkgver = 0.93.6
- pkgrel = 2
+ pkgver = 0.93.7
+ pkgrel = 1
url = https://github.com/guoci/autokey-py3
install = autokey-py3.install
arch = any
@@ -19,19 +19,17 @@ pkgbase = autokey-py3
depends = xorg-xwd
depends = python-xlib
depends = python-six
- optdepends = python-gobject: for GTK GUI
- optdepends = gtksourceview3: for GTK GUI
- optdepends = libnotify: for GTK GUI
- optdepends = python-qscintilla: for QT GUI
- optdepends = kdebindings-python: for QT GUI
+ depends = python-gobject
+ depends = gtksourceview3
+ depends = libnotify
+ depends = libappindicator-gtk3
+ optdepends = python-qscintilla: for QT GUI (deprecated)
+ optdepends = kdebindings-python: for QT GUI (deprecated)
conflicts = autokey
conflicts = autokey-gtk
- conflicts = autokey-qt
conflicts = autokey-data
- source = https://pypi.io/packages/source/a/autokey-py3/autokey-py3-0.93.6.tar.gz
- source = setup-kde4-fix.patch
- sha256sums = 2428bf22ffd036bb30b17195f3c8e9384ad832008e6cde161fecb823efb47339
- sha256sums = d117331d6024049e4557e485d1669d28b16ab75d8ef55a4fcb2243828bc9f956
+ source = https://github.com/autokey-py3/autokey/archive/v0.93.7.tar.gz
+ sha256sums = 28a7efd4d4e82df0f41c33bffc56acecb9396e355392a9591f3950c27e8c1efe
pkgname = autokey-py3
diff --git a/PKGBUILD b/PKGBUILD
index ec94a57d1caa..8b0cd198be24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,28 @@
# Maintainer: Dmitry Kharitonov <darksab0r@gmail.com>
# Contributor: Dave Blair <mail@dave-blair.de>
pkgname=autokey-py3
-pkgver=0.93.6
-pkgrel=2
+pkgver=0.93.7
+pkgrel=1
pkgdesc="Python 3 port of AutoKey, a desktop automation utility for Linux and X11 with new features."
url="https://github.com/guoci/autokey-py3"
depends=('python' 'wmctrl' 'hicolor-icon-theme' 'python-dbus' 'python-pyinotify' \
- 'zenity' 'xautomation' 'imagemagick' 'xorg-xwd' 'python-xlib' 'python-six')
-optdepends=('python-gobject: for GTK GUI'
- 'gtksourceview3: for GTK GUI'
- 'libnotify: for GTK GUI'
- 'python-qscintilla: for QT GUI'
- 'kdebindings-python: for QT GUI')
-conflicts=('autokey' 'autokey-gtk' 'autokey-qt' 'autokey-data')
+ 'zenity' 'xautomation' 'imagemagick' 'xorg-xwd' 'python-xlib' 'python-six'
+ 'python-gobject' 'gtksourceview3' 'libnotify' 'libappindicator-gtk3')
+optdepends=('python-qscintilla: for QT GUI (deprecated)'
+ 'kdebindings-python: for QT GUI (deprecated)')
+conflicts=('autokey' 'autokey-gtk' 'autokey-data')
license=('GPL3')
arch=('any')
-source=("https://pypi.io/packages/source/a/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "setup-kde4-fix.patch")
-sha256sums=('2428bf22ffd036bb30b17195f3c8e9384ad832008e6cde161fecb823efb47339'
- 'd117331d6024049e4557e485d1669d28b16ab75d8ef55a4fcb2243828bc9f956')
+source=("https://github.com/autokey-py3/autokey/archive/v${pkgver}.tar.gz")
+sha256sums=('28a7efd4d4e82df0f41c33bffc56acecb9396e355392a9591f3950c27e8c1efe')
install=$pkgname.install
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p0 -i ../setup-kde4-fix.patch
-}
-
-
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/autokey-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/autokey-${pkgver}"
python setup.py install --root="$pkgdir" --optimize=1
}
diff --git a/setup-kde4-fix.patch b/setup-kde4-fix.patch
deleted file mode 100644
index cc426b1c2847..000000000000
--- a/setup-kde4-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py 2016-06-18 12:47:26.959381545 +0500
-+++ setup.py.1 2016-06-18 12:47:36.672853442 +0500
-@@ -52,7 +52,7 @@
- ("share/icons/ubuntu-mono-light/apps/48", ["config/ubuntu-mono-light/autokey-status.svg", "config/ubuntu-mono-light/autokey-status-error.svg"]),
- ("share/applications", ["config/autokey-qt.desktop", "config/autokey-gtk.desktop"]),
- ('share/man/man1/', ['doc/man/autokey-qt.1', 'doc/man/autokey-gtk.1', 'doc/man/autokey-run.1']),
-- ('share/kde4/apps/autokey' , ['config/autokeyui.rc'])],
-+ ('share/apps/autokey' , ['config/autokeyui.rc'])],
- scripts=['autokey-qt', 'autokey-gtk', 'autokey-run', 'autokey-shell'],
- classifiers = [
- 'Development Status :: 4 - Beta',