summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2018-08-22 01:40:26 +0500
committerDmitry Kharitonov2018-08-22 01:40:26 +0500
commitcb341d3e9abf3e10b4e3d491e3d9428f68af82ed (patch)
tree8c1c98748d181e161b4a2f582670360a9de9f855
parenta8e273f37edf7a7f0db2b3e4b36331065a4bdcde (diff)
downloadaur-cb341d3e9abf3e10b4e3d491e3d9428f68af82ed.tar.gz
Updated to 0.95.3
Removed atspi.patch as upstream now takes care of it Removed python-xlib from requires.patch, only dbus-python left
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--atspi.patch11
-rw-r--r--requires.patch2
4 files changed, 10 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49b792ab7024..000967d455f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autokey-py3
pkgdesc = Python 3 port of AutoKey, a desktop automation utility for Linux and X11 with new features.
- pkgver = 0.95.2
- pkgrel = 5
+ pkgver = 0.95.3
+ pkgrel = 1
url = https://github.com/autokey/autokey
arch = any
license = GPL3
@@ -30,12 +30,10 @@ pkgbase = autokey-py3
conflicts = autokey
conflicts = autokey-gtk
conflicts = autokey-data
- source = autokey-py3-0.95.2.tar.gz::https://github.com/autokey-py3/autokey/archive/v0.95.2.tar.gz
- source = atspi.patch
+ source = autokey-py3-0.95.3.tar.gz::https://github.com/autokey-py3/autokey/archive/v0.95.3.tar.gz
source = requires.patch
- sha256sums = 2354d0ea45b6d4dafdb9da9b9d046e204616f2612c8c21ac36550e88f362b499
- sha256sums = 1e5014aec1a8a1b6bdb292e6c1c8133e885bfe9b5c04691e786393776f30b8fd
- sha256sums = 4e33374c4eff96573ce92fda5e8263c8a610c9ba9fdce98046a0a3a05ac9a478
+ sha256sums = 895749bfcc515d6bdeacc3192afba4263e91a8ad6ee9db42b983db67da3b847c
+ sha256sums = b904d9e336e5fa6480820148e4394aedfbfa2d3662b1ae38d03a200a9bcbbdd8
pkgname = autokey-py3
diff --git a/PKGBUILD b/PKGBUILD
index 8e3f0a988eec..337e4f9f742c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Dave Blair <mail@dave-blair.de>
pkgname=autokey-py3
-pkgver=0.95.2
-pkgrel=5
+pkgver=0.95.3
+pkgrel=1
pkgdesc="Python 3 port of AutoKey, a desktop automation utility for Linux and X11 with new features."
url="https://github.com/autokey/autokey"
depends=('python' 'wmctrl' 'hicolor-icon-theme' 'python-dbus' 'python-pyinotify'
@@ -20,16 +20,13 @@ conflicts=('autokey' 'autokey-gtk' 'autokey-data')
license=('GPL3')
arch=('any')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/autokey-py3/autokey/archive/v${pkgver}.tar.gz"
- "atspi.patch"
"requires.patch")
-sha256sums=('2354d0ea45b6d4dafdb9da9b9d046e204616f2612c8c21ac36550e88f362b499'
- '1e5014aec1a8a1b6bdb292e6c1c8133e885bfe9b5c04691e786393776f30b8fd'
- '4e33374c4eff96573ce92fda5e8263c8a610c9ba9fdce98046a0a3a05ac9a478')
+sha256sums=('895749bfcc515d6bdeacc3192afba4263e91a8ad6ee9db42b983db67da3b847c'
+ 'b904d9e336e5fa6480820148e4394aedfbfa2d3662b1ae38d03a200a9bcbbdd8')
prepare() {
cd "$srcdir/autokey-${pkgver}"
patch -Np1 -i ../requires.patch
- patch -Np1 -i ../atspi.patch
}
package() {
diff --git a/atspi.patch b/atspi.patch
deleted file mode 100644
index 5d3c1796801a..000000000000
--- a/atspi.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /lib/autokey/interface.py
-+++ /lib/autokey/interface.py
-@@ -57,6 +57,8 @@
- HAS_ATSPI = False
- except ValueError:
- HAS_ATSPI = False
-+ except SyntaxError: # pyatspi 2.26 fails when used with Python 3.7
-+ HAS_ATSPI = False
-
- from Xlib import X, XK, display, error
- try:
diff --git a/requires.patch b/requires.patch
index 5e0ef5763e6f..930494d7876f 100644
--- a/requires.patch
+++ b/requires.patch
@@ -4,7 +4,7 @@
]
},
scripts=['autokey-run', 'autokey-shell'],
-- install_requires=['dbus-python', 'pyinotify', 'python3-xlib'],
+- install_requires=['dbus-python', 'pyinotify', 'python-xlib'],
+ install_requires=['pyinotify', 'python-xlib'],
classifiers=[
'Development Status :: 4 - Beta',