summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorallddd2022-11-26 03:31:42 +0100
committerallddd2022-11-26 03:31:42 +0100
commitb68ce515488edff17002575864b8f364292e6573 (patch)
tree6b10e1716adce92c060b690b0d0c675bfffac49d
downloadaur-b68ce515488edff17002575864b8f364292e6573.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e3fbb483f21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = autolibheif
+ pkgdesc = CLI utility for encoding and decoding the HEIF/HEIC file format
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/allddd/autolibheif
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = libheif
+ depends = python
+ source = https://github.com/allddd/autolibheif/archive/refs/tags/v1.0.0.tar.gz
+ sha256sums = 297e9f5292ef609e63c470e2effb0c7aa45b4ebf6dbf0c78d98fd1f671be4392
+
+pkgname = autolibheif
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e70e35d33ef3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Alld Ovina <allddd (at) proton (dot) me>
+pkgname=autolibheif
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="CLI utility for encoding and decoding the HEIF/HEIC file format"
+arch=('x86_64')
+url="https://github.com/allddd/autolibheif"
+license=('MIT')
+depends=('libheif' 'python')
+makedepends=('python-setuptools')
+optdepends=()
+source=(${url}/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('297e9f5292ef609e63c470e2effb0c7aa45b4ebf6dbf0c78d98fd1f671be4392')
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}