summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-19 22:27:09 +0800
committerChocobo12017-08-19 22:46:12 +0800
commitd02b2c9e646c6ede70d248c715a48acfa41230a3 (patch)
treec626337ff5c6caf8b077e4c1feb517a8ea9bc983
downloadaur-d02b2c9e646c6ede70d248c715a48acfa41230a3.tar.gz
newpkg: automake-git 1.15.r180.gcc7231cc3-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bae0a52f82f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = automake-git
+ pkgdesc = A tool for automatically generating Makefiles
+ pkgver = 1.15.r180.gcc7231cc3
+ pkgrel = 1
+ url = https://www.gnu.org/software/automake/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = sh
+ depends = perl
+ provides = automake
+ conflicts = automake
+ source = git+https://git.savannah.gnu.org/git/automake.git
+ sha256sums = SKIP
+
+pkgname = automake-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81b71c3e6d00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=automake-git
+pkgver=1.15.r180.gcc7231cc3
+pkgrel=1
+pkgdesc="A tool for automatically generating Makefiles"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/automake/"
+license=('GPL2')
+depends=('sh' 'perl')
+makedepends=('git')
+provides=('automake')
+conflicts=('automake')
+source=("git+https://git.savannah.gnu.org/git/automake.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "automake"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "automake"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "automake"
+
+ #make check
+}
+
+package() {
+ cd "automake"
+
+ make DESTDIR="$pkgdir" install
+}