summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflorianmw2020-05-03 20:54:19 +0200
committerflorianmw2020-05-03 21:22:59 +0200
commita8bd6e47fcb27f910575dfee66bde44bd4cd0384 (patch)
tree03ba1234968a8f1521b7d25ad10e45aad6d3003d
parente74a584a5f659051094e88887a0ccaa3789f86cd (diff)
downloadaur-a8bd6e47fcb2.tar.gz
remove auto enable of timer and autostart
-rw-r--r--PKGBUILD2
-rw-r--r--automathemely.install41
2 files changed, 10 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51009f3592e4..4af232975f2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ source=("https://github.com/C2N14/${_name}/archive/v${pkgver}.tar.gz"
${pkgname}.timer
)
sha256sums=('14e5100eb911ab8e5667a3358e1e7ed6540fd1a294ba4d451d4db480b08c3555'
- 'd89733856d5d93f93ca29ea769c6ae3e2841378c89b88fe1acd239fa7dd5026f'
+ 'b853ded02b52867e4695c7df10aa7559f8b2c4eb98761aca20e9a856cc1294e0'
'6c0e4e6076f2cce0cef8c5aec79f9ea6106240051b1d556eabea4c391fe0d834'
'0b39fc8abf200b1438b01deb48133817e4dc1cd6e7e41cebe7e82118ed96999e')
diff --git a/automathemely.install b/automathemely.install
index 738daec35565..53b0086fda6b 100644
--- a/automathemely.install
+++ b/automathemely.install
@@ -1,40 +1,17 @@
post_install() {
- # start timer for all users automatically after install
- if systemctl --global enable automathemely.timer
- then
- cat <<EOM
+ cat <<EOM
- Timer to update automathemely sun times enabled.
- Please note that the timer only starts on a new user session.
- To disable the timer run "systemctl disable --user automathemely.timer" as user
+ In order to use automatic theme updates with automathemely the timer and autostart needs to be enabled
+ To enable the timer for your user run:
-EOM
- else
- cat <<EOM
-
- Failed to enable timer to update automathemely sun times
- To enable the timer for your user run "systemctl enable --user automathemely.timer"
+ systemctl enable --user automathemely.timer
-EOM
- fi
+ For autostart (globally) this command can be used:
- # install to autostart; remove '--manage' from command
- sed 's/\(Exec=automathemely\)\ \-\-manage/\1/'\
- /usr/share/applications/automathemely.desktop >|\
- /etc/xdg/autostart/automathemely.desktop
-}
+ sed 's/\(Exec=automathemely\)\ \-\-manage/\1/' \\
+ /usr/share/applications/automathemely.desktop >| \\
+ /etc/xdg/autostart/automathemely.desktop
-post_upgrade() {
- # start timer for upgrade from less than 1.3-2
- if [ $(vercmp $2 1.3-2) -lt 0 ]
- then
- post_install
- fi
-}
-
-pre_remove() {
- # disable the timer before remove
- systemctl --global disable automathemely.timer
- rm -v /etc/xdg/autostart/automathemely.desktop
+EOM
}