summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2018-08-24 06:45:17 +0000
committerAntonio Rojas2018-08-24 06:45:17 +0000
commit4f2a84b7c7d086a379124b447710d0aab21336b5 (patch)
treef2f45eb299c910c29597fdf5f164cf4d9c7e2fb2
downloadaur-automoc4.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--fix-cmake-warnings.patch39
-rw-r--r--license.txt31
4 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d71e8c226690
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = automoc4
+ pkgdesc = Automatic moc for Qt4
+ pkgver = 0.9.88
+ pkgrel = 9
+ url = http://www.kde.org/
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ depends = qt4
+ source = http://download.kde.org/stable/automoc4/0.9.88/automoc4-0.9.88.tar.bz2
+ source = license.txt
+ source = fix-cmake-warnings.patch
+ sha256sums = 234116f4c05ae21d828594d652b4c4a052ef75727e2d8a4f3a4fb605de9e4c49
+ sha256sums = d99c6d161e46c23c46f027c76c1d2e134acffb08636cd0ede2e98a4825d7ea78
+ sha256sums = db3fcf5a95d7e02b97c2f90c76919210d4877dd3ca3c55aa6a367c08a466fefc
+
+pkgname = automoc4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3972c1ac72d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 325213 2018-05-30 20:19:53Z arojas $
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=automoc4
+pkgver=0.9.88
+pkgrel=9
+pkgdesc="Automatic moc for Qt4"
+arch=(x86_64)
+url='http://www.kde.org/'
+license=(custom)
+depends=(qt4)
+makedepends=(cmake)
+source=("http://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+ license.txt fix-cmake-warnings.patch)
+sha256sums=('234116f4c05ae21d828594d652b4c4a052ef75727e2d8a4f3a4fb605de9e4c49'
+ 'd99c6d161e46c23c46f027c76c1d2e134acffb08636cd0ede2e98a4825d7ea78'
+ 'db3fcf5a95d7e02b97c2f90c76919210d4877dd3ca3c55aa6a367c08a466fefc')
+
+prepare() {
+ mkdir -p build
+
+# Fix CMake warnings with newer policies
+ cd $pkgname-$pkgver
+ patch -p1 -i ../fix-cmake-warnings.patch
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/fix-cmake-warnings.patch b/fix-cmake-warnings.patch
new file mode 100644
index 000000000000..8d74784a82f2
--- /dev/null
+++ b/fix-cmake-warnings.patch
@@ -0,0 +1,39 @@
+From: Stephen Kelly <steveire@gmail.com>
+Date: Sun, 19 Jul 2015 19:24:51 +0000
+Subject: Don't attempt to add dependencies which do not exist.
+X-Git-Url: http://quickgit.kde.org/?p=automoc.git&a=commitdiff&h=48f6e64d98e4aaa47f2a49faa5f3e821bc21fd6e
+---
+Don't attempt to add dependencies which do not exist.
+---
+
+
+--- a/Automoc4Config.cmake
++++ b/Automoc4Config.cmake
+@@ -132,7 +132,6 @@
+ if(_moc_files)
+ set(_automoc_source "${CMAKE_CURRENT_BINARY_DIR}/${_target_NAME}_automoc.cpp")
+ get_directory_property(_moc_incs INCLUDE_DIRECTORIES)
+- get_directory_property(_moc_defs DEFINITIONS)
+ get_directory_property(_moc_cdefs COMPILE_DEFINITIONS)
+
+ # Assume CMAKE_INCLUDE_CURRENT_DIR is set
+@@ -198,7 +197,6 @@
+ set(_automoc_source "${CMAKE_CURRENT_BINARY_DIR}/${_target_NAME}.cpp")
+ set(_automoc_dotFiles "${CMAKE_CURRENT_BINARY_DIR}/${_target_NAME}.cpp.files")
+ get_directory_property(_moc_incs INCLUDE_DIRECTORIES)
+- get_directory_property(_moc_defs DEFINITIONS)
+ get_directory_property(_moc_cdefs COMPILE_DEFINITIONS)
+
+ # Assume CMAKE_INCLUDE_CURRENT_DIR is set
+@@ -274,7 +272,9 @@
+
+
+ macro(_AUTOMOC4_KDE4_POST_TARGET_HANDLING _target)
+- add_dependencies(${_target} "${_target}_automoc")
++ if (TARGET "${_target}_automoc")
++ add_dependencies(${_target} "${_target}_automoc")
++ endif()
+ endmacro(_AUTOMOC4_KDE4_POST_TARGET_HANDLING)
+
+
+
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..f9db6034072c
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,31 @@
+Upstream Authors:
+
+ Mathias Kretz <kretz@kde.org>
+ Alexander Neundorff <neundorff@kde.org>
+
+Copyright:
+
+ Copyright (c) 2007 Mathias Kretz <kretz@kde.org>
+
+License:
+
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+ IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+ NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+ THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.