summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 21:34:37 -0600
committerBrian Bidulock2015-07-08 21:34:37 -0600
commit1440700a8570da0eff7078c1c4c5a49f07e6ccc2 (patch)
tree9b5a5d342f6afea53356e5ffae951659ae5a3431
downloadaur-1440700a8570da0eff7078c1c4c5a49f07e6ccc2.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--automounter.install11
-rw-r--r--mount-archive.desktop10
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c0c4029e1e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = automounter
+ pkgdesc = This is a link to gvfs-archive that will allow automounting of ISOs and other files, UBUNTU/FEDORA style
+ pkgver = 0.1
+ pkgrel = 3
+ url = https://bbs.archlinux.org/viewtopic.php?pid=606881
+ install = automounter.install
+ arch = any
+ license = GPL
+ depends = gvfs
+ depends = desktop-file-utils
+ source = mount-archive.desktop
+ md5sums = 73890777b05aaa4e97c50e26c49cd7dc
+
+pkgname = automounter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ae015b4fc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Giorgio Gilestro <giorgio@gilest.ro>
+
+pkgname=automounter
+pkgver=0.1
+pkgrel=3
+pkgdesc="This is a link to gvfs-archive that will allow automounting of ISOs and other files, UBUNTU/FEDORA style"
+url="https://bbs.archlinux.org/viewtopic.php?pid=606881"
+depends=('gvfs' 'desktop-file-utils')
+license=('GPL')
+arch=('any')
+install=$pkgname.install
+source=("mount-archive.desktop")
+md5sums=('73890777b05aaa4e97c50e26c49cd7dc')
+
+package() {
+ mkdir -p $pkgdir/usr/share/applications/
+ install $srcdir/mount-archive.desktop $pkgdir/usr/share/applications/
+}
+
diff --git a/automounter.install b/automounter.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/automounter.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/mount-archive.desktop b/mount-archive.desktop
new file mode 100644
index 000000000000..3fd57ae1fc72
--- /dev/null
+++ b/mount-archive.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Archive Mounter
+Icon=gtk-cdrom
+Exec=/usr/lib/gvfs/gvfsd-archive file=%u
+MimeType=application/x-cd-image;application/x-bzip-compressed-tar;application/x-compressed-tar;application/x-tar;application/x-cpio;application/zip;
+Terminal=false
+StartupNotify=false
+Type=Application
+NoDisplay=true