summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-01-15 23:15:57 +0100
committerjose17112016-01-15 23:15:57 +0100
commit2fd8a79bca1e3d204233460b365e577414b519c3 (patch)
tree7b2baba3b4c0eab700ff6ebf6eaf574acfd9e76a
downloadaur-2fd8a79bca1e3d204233460b365e577414b519c3.tar.gz
adopted from aur3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aa61d8d2099
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Jan 15 22:15:50 UTC 2016
+pkgbase = autopano-sift-c
+ pkgdesc = Identify key feature points within arbitrary images
+ pkgver = 2.5.1
+ pkgrel = 4
+ url = http://hugin.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = libxml2
+ depends = libpano13
+ depends = gcc-libs
+ provides = autopano-sift
+ conflicts = autopano-sift
+ replaces = autopano-sift
+ source = http://downloads.sourceforge.net/sourceforge/hugin/autopano-sift-C-2.5.1.tar.gz
+ md5sums = b9bade07e8c4f2ea383c22a082c260e0
+
+pkgname = autopano-sift-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38804081cc84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 146968 2012-01-19 19:15:55Z eric $
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Tobias Kieslich <tobias@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
+pkgname=autopano-sift-c
+pkgver=2.5.1
+pkgrel=4
+pkgdesc="Identify key feature points within arbitrary images"
+arch=('i686' 'x86_64')
+url="http://hugin.sourceforge.net/"
+license=('GPL2')
+depends=('libxml2' 'libpano13' 'gcc-libs')
+makedepends=('cmake')
+provides=('autopano-sift')
+conflicts=('autopano-sift')
+replaces=('autopano-sift')
+source=(http://downloads.sourceforge.net/sourceforge/hugin/autopano-sift-C-${pkgver}.tar.gz)
+md5sums=('b9bade07e8c4f2ea383c22a082c260e0')
+
+build() {
+ cd "${srcdir}/autopano-sift-C-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ sed -i 's/-lz/-lz -lm/' CMakeFiles/{autopano,generatekeys}.dir/link.txt
+ make
+}
+
+package() {
+ cd "${srcdir}/autopano-sift-C-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}