summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Repomaa2019-11-15 16:02:31 +0100
committerJoakim Repomaa2019-11-15 16:02:31 +0100
commit9cffe19af2921dfeeaebaa103f0e998bb6f83f44 (patch)
tree4b0620378fd21c34fb9d5674ad8ddb5e27676a2a
parente20554cd7a93e3bc1629cf0cebffd5d82e9d4dc1 (diff)
downloadaur-9cffe19af2921dfeeaebaa103f0e998bb6f83f44.tar.gz
add systemd socket activation service and socket units
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--autopass.service5
-rw-r--r--autopass.socket9
4 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abc0eb3c15d6..b6cbffcfeed2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Nov 15 14:49:06 UTC 2019
+# Fri Nov 15 15:02:22 UTC 2019
pkgbase = autopass.cr
pkgdesc = a rofi frontend for pass
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/repomaa/autopass.cr
arch = x86_64
license = MIT
@@ -26,8 +26,12 @@ pkgbase = autopass.cr
conflicts = autopass.cr-bin
source = https://gitlab.com/repomaa/autopass.cr/-/archive/v0.2.0/autopass.cr-v0.2.0.tar.gz
source = https://gitlab.com/repomaa/autopass.cr/uploads/52cc5f7f2ff2f2e492e054eb29930e8f/autopass.cr-v0.2.0.tar.gz.sig
+ source = autopass.socket
+ source = autopass.service
md5sums = 470db1b54a4d846e55ce941022e87bf5
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = autopass.cr
diff --git a/PKGBUILD b/PKGBUILD
index f44bb25f5279..dfd41fa6a2cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=autopass.cr
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='a rofi frontend for pass'
arch=(x86_64)
url='https://gitlab.com/repomaa/autopass.cr'
@@ -13,10 +13,14 @@ makedepends=(crystal shards rust git python)
source=(
"https://gitlab.com/repomaa/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
"https://gitlab.com/repomaa/autopass.cr/uploads/52cc5f7f2ff2f2e492e054eb29930e8f/autopass.cr-v0.2.0.tar.gz.sig"
+ 'autopass.socket'
+ 'autopass.service'
)
md5sums=(
470db1b54a4d846e55ce941022e87bf5
SKIP
+ SKIP
+ SKIP
)
validpgpkeys=(CC7BD43A315EBC373F9A1F2EEFEB16CB1C8952C5)
provides=('autopass')
@@ -32,6 +36,8 @@ package() {
cd "${pkgname}-v${pkgver}"
install -Dm755 bin/autopass "$pkgdir/usr/bin/autopass"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 autopass.socket "$pkgdir/usr/lib/systemd/user/autopass.socket"
+ install -Dm644 autopass.service "$pkgdir/usr/lib/systemd/user/autopass.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/autopass.service b/autopass.service
new file mode 100644
index 000000000000..a38799ad01b9
--- /dev/null
+++ b/autopass.service
@@ -0,0 +1,5 @@
+[Unit]
+Description=Socket activated autopass
+
+[Service]
+ExecStart=/usr/bin/autopass
diff --git a/autopass.socket b/autopass.socket
new file mode 100644
index 000000000000..188e39351b79
--- /dev/null
+++ b/autopass.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=Socket activation for autopass
+
+[Socket]
+ListenFIFO=%t/autopass.fifo
+SocketMode=0600
+
+[Install]
+WantedBy=default.target