summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Repomaa2019-11-15 15:51:06 +0100
committerJoakim Repomaa2019-11-15 15:51:06 +0100
commit16426f4ece73f3e84f60a335db46caa98987759f (patch)
treea890fba615c31b7539d4165812924e532d7e5345
downloadaur-16426f4ece73f3e84f60a335db46caa98987759f.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD32
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09f1e0ce5da7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Fri Nov 15 14:50:58 UTC 2019
+pkgbase = autopass.cr-bin
+ pkgdesc = a rofi frontend for pass
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://gitlab.com/repomaa/autopass.cr
+ arch = x86_64
+ license = MIT
+ depends = pass
+ depends = rofi
+ depends = xdotool
+ depends = gpgme
+ depends = gc
+ depends = libyaml
+ depends = libevent
+ optdepends = passed-git: batch editing of pass entries with sed
+ provides = autopass
+ conflicts = autopass
+ conflicts = autopass.cr
+ conflicts = autopass.cr-git
+ source = https://gitlab.com/repomaa/autopass.cr/uploads/a953c14bdfa7206ad5e9fe1e8b8d30eb/autopass
+ source = https://gitlab.com/repomaa/autopass.cr/uploads/d686f12a4e15988d424a03e5efb85a8d/autopass.sig
+ source = https://gitlab.com/repomaa/autopass.cr/raw/v0.2.0/LICENSE
+ md5sums = 30c8edd39c0798f60b6eb8831632bef2
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = autopass.cr-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2849769bcc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joakim Repomaa <aur@j.repomaa.com>
+
+pkgname=autopass.cr-bin
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='a rofi frontend for pass'
+arch=(x86_64)
+url='https://gitlab.com/repomaa/autopass.cr'
+license=('MIT')
+depends=(pass rofi xdotool gpgme gc libyaml libevent)
+
+source=(
+ 'https://gitlab.com/repomaa/autopass.cr/uploads/a953c14bdfa7206ad5e9fe1e8b8d30eb/autopass'
+ 'https://gitlab.com/repomaa/autopass.cr/uploads/d686f12a4e15988d424a03e5efb85a8d/autopass.sig'
+ "https://gitlab.com/repomaa/autopass.cr/raw/v${pkgver}/LICENSE"
+)
+md5sums=(
+ 30c8edd39c0798f60b6eb8831632bef2
+ SKIP
+ SKIP
+)
+validpgpkeys=(CC7BD43A315EBC373F9A1F2EEFEB16CB1C8952C5)
+provides=('autopass')
+conflicts=('autopass' 'autopass.cr' 'autopass.cr-git')
+optdepends=('passed-git: batch editing of pass entries with sed')
+
+package() {
+ install -Dm755 autopass "$pkgdir/usr/bin/autopass"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: