summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Repomaa2019-11-15 15:57:10 +0100
committerJoakim Repomaa2019-11-15 15:57:52 +0100
commit21cb0954d59710601428c7531fd28b8b27762bbf (patch)
tree3fc2b165a8abb22a516d72454502af24cb8e7fc2
parent16426f4ece73f3e84f60a335db46caa98987759f (diff)
downloadaur-21cb0954d59710601428c7531fd28b8b27762bbf.tar.gz
add socket activation service and socket units
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--autopass.service5
-rw-r--r--autopass.socket9
4 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09f1e0ce5da7..889735a2eef4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Nov 15 14:50:58 UTC 2019
+# Fri Nov 15 14:57:00 UTC 2019
pkgbase = autopass.cr-bin
pkgdesc = a rofi frontend for pass
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/repomaa/autopass.cr
arch = x86_64
license = MIT
@@ -22,9 +22,13 @@ pkgbase = autopass.cr-bin
source = https://gitlab.com/repomaa/autopass.cr/uploads/a953c14bdfa7206ad5e9fe1e8b8d30eb/autopass
source = https://gitlab.com/repomaa/autopass.cr/uploads/d686f12a4e15988d424a03e5efb85a8d/autopass.sig
source = https://gitlab.com/repomaa/autopass.cr/raw/v0.2.0/LICENSE
+ source = autopass.service
+ source = autopass.socket
md5sums = 30c8edd39c0798f60b6eb8831632bef2
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = autopass.cr-bin
diff --git a/PKGBUILD b/PKGBUILD
index d2849769bcc0..40303439b944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=autopass.cr-bin
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='a rofi frontend for pass'
arch=(x86_64)
url='https://gitlab.com/repomaa/autopass.cr'
@@ -13,11 +13,15 @@ source=(
'https://gitlab.com/repomaa/autopass.cr/uploads/a953c14bdfa7206ad5e9fe1e8b8d30eb/autopass'
'https://gitlab.com/repomaa/autopass.cr/uploads/d686f12a4e15988d424a03e5efb85a8d/autopass.sig'
"https://gitlab.com/repomaa/autopass.cr/raw/v${pkgver}/LICENSE"
+ 'autopass.service'
+ 'autopass.socket'
)
md5sums=(
30c8edd39c0798f60b6eb8831632bef2
SKIP
SKIP
+ SKIP
+ SKIP
)
validpgpkeys=(CC7BD43A315EBC373F9A1F2EEFEB16CB1C8952C5)
provides=('autopass')
@@ -27,6 +31,8 @@ optdepends=('passed-git: batch editing of pass entries with sed')
package() {
install -Dm755 autopass "$pkgdir/usr/bin/autopass"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 autopass.socket "$pkgdir/usr/lib/systemd/user/autopass.socket"
+ install -Dm644 autopass.service "$pkgdir/usr/lib/systemd/user/autopass.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/autopass.service b/autopass.service
new file mode 100644
index 000000000000..a38799ad01b9
--- /dev/null
+++ b/autopass.service
@@ -0,0 +1,5 @@
+[Unit]
+Description=Socket activated autopass
+
+[Service]
+ExecStart=/usr/bin/autopass
diff --git a/autopass.socket b/autopass.socket
new file mode 100644
index 000000000000..188e39351b79
--- /dev/null
+++ b/autopass.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=Socket activation for autopass
+
+[Socket]
+ListenFIFO=%t/autopass.fifo
+SocketMode=0600
+
+[Install]
+WantedBy=default.target