summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdgard Castro2016-12-02 03:44:17 -0200
committerEdgard Castro2016-12-02 03:44:17 -0200
commit08cbf3162fca48b701f056ee4b1a6fd504085026 (patch)
tree1bfcd7641af9bb002b8dd96c517e9cfdb864e141
parent6727b5242c588e01e3b42636be240a2acaedeb27 (diff)
downloadaur-08cbf3162fca48b701f056ee4b1a6fd504085026.tar.gz
cleanup pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD40
2 files changed, 21 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9e6aca1c222..51df1b118c3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = autorandr-git
pkgdesc = Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support.
- pkgver = r240.53d29f9
+ pkgver = r244.9b1ef49
pkgrel = 1
url = https://github.com/phillipberndt/autorandr
install = autorandr-git.install
@@ -17,7 +17,7 @@ pkgbase = autorandr-git
conflicts = auto-disper-git
conflicts = autorandr-asch-git
conflicts = autorandr-phillipberndt-git
- source = autorandr::git+https://github.com/phillipberndt/autorandr.git
+ source = autorandr-git::git+https://github.com/phillipberndt/autorandr.git
source = autorandr-git.install
sha256sums = SKIP
sha256sums = 60c035d6f433d388ef1d3acec084dcd021158cbec79e9807e78cc368cb499690
diff --git a/PKGBUILD b/PKGBUILD
index 3fd32b7d5882..f69d5e7c4139 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,46 +6,44 @@
# Contributor: phillipberndt (maintainer of the current autorandr)
# Contributor: wertarbyte (original author of auto-disper and autorandr)
-_pkgname=autorandr
pkgname=autorandr-git
-pkgver=r240.53d29f9
+pkgver=r244.9b1ef49
pkgrel=1
-pkgdesc='Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support.'
+pkgdesc="Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support."
arch=('any')
-url="https://github.com/phillipberndt/autorandr"
+url="https://github.com/phillipberndt/${pkgname%-git}"
license=('GPL3')
depends=('python' 'xorg-xrandr')
makedepends=('git')
optdepends=(
- 'pm-utils: For changing autorandr profile on thaw/resume'
- 'python2: For using autorandr_monitor'
- 'xorg-xdpyinfo: For detecting the primary XRandR output'
+ "pm-utils: For changing autorandr profile on thaw/resume"
+ "python2: For using autorandr_monitor"
+ "xorg-xdpyinfo: For detecting the primary XRandR output"
)
-provides=('autorandr')
+provides=("${pkgname%-git}")
conflicts=(
- 'autorandr'
- 'auto-disper-git'
- 'autorandr-asch-git'
- 'autorandr-phillipberndt-git'
+ "${pkgname%-git}"
+ "auto-disper-git"
+ "autorandr-asch-git"
+ "autorandr-phillipberndt-git"
)
-install="$pkgname.install"
+install="${pkgname}.install"
source=(
- "$_pkgname"::"git+https://github.com/phillipberndt/$_pkgname.git"
- "$pkgname.install"
+ "${pkgname}::git+${url}.git"
+ "${pkgname}.install"
)
sha256sums=('SKIP'
- '60c035d6f433d388ef1d3acec084dcd021158cbec79e9807e78cc368cb499690')
+ '60c035d6f433d388ef1d3acec084dcd021158cbec79e9807e78cc368cb499690')
pkgver() {
- cd "$_pkgname"
- (
- set -o pipefail
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
) 2>/dev/null
}
package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
}