summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2016-11-22 18:32:46 -0800
committerMike Swanson2016-11-22 18:33:18 -0800
commit294790e7da7c66738556fa6a73b0485c493aecaf (patch)
tree36601d7db6f2e126d75759e0a0226f696a477349
parent12c47b7b1e4e884a2b9f0c3ead4242fca861cc62 (diff)
downloadaur-294790e7da7c66738556fa6a73b0485c493aecaf.tar.gz
Use PGP signature verification.
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD12
3 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e74aa3ff83cd..a85d81197154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Wed Nov 23 01:17:38 UTC 2016
+# Wed Nov 23 02:32:57 UTC 2016
pkgbase = autorevision
pkgdesc = Extracts metadata about the HEAD of a repository
pkgver = 1.18
- pkgrel = 1
+ pkgrel = 2
url = https://autorevision.github.io/
arch = any
license = BSD
makedepends = asciidoc
- source = https://github.com/Autorevision/autorevision/archive/v/1.18.tar.gz
- sha256sums = a213e1bbab39c84c4832a70b8980473a547923bfe75135459d686226a0cd33f3
+ source = https://github.com/Autorevision/autorevision/releases/download/v%2F1.18/autorevision-1.18.tgz
+ source = https://github.com/Autorevision/autorevision/releases/download/v%2F1.18/autorevision-1.18.tgz.sig
+ sha256sums = 1f78dd8e9671fa00d96d2d4479235950d8d8637f59bc38b1b622638cf0225e87
+ sha256sums = SKIP
pkgname = autorevision
diff --git a/.gitignore b/.gitignore
index feddb330f1c8..2b05fc061241 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
/autorevision.cache
*.pkg.tar*
*.src.tar*
-*.tar.gz
+*.tgz
+*.tgz.sig
src
pkg
diff --git a/PKGBUILD b/PKGBUILD
index ef0dfed3c3ba..a6a061471a46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=autorevision
pkgver=1.18
-pkgrel=1
+pkgrel=2
pkgdesc="Extracts metadata about the HEAD of a repository"
arch=('any')
url="https://autorevision.github.io/"
license=('BSD')
makedepends=('asciidoc')
-source=(https://github.com/Autorevision/autorevision/archive/v/${pkgver}.tar.gz)
-sha256sums=('a213e1bbab39c84c4832a70b8980473a547923bfe75135459d686226a0cd33f3')
+source=(https://github.com/Autorevision/autorevision/releases/download/v%2F1.18/${pkgname}-${pkgver}.tgz{,.sig})
+sha256sums=('1f78dd8e9671fa00d96d2d4479235950d8d8637f59bc38b1b622638cf0225e87'
+ 'SKIP')
+validpgpkeys=('A16E4FE1BFE882DE9D6E28AD0044B6E72C414317')
build() {
- cd "$pkgname-v-${pkgver}"
+ cd "$pkgname-${pkgver}"
make VERS=$pkgver
fmt < COPYING.md > COPYING
}
package() {
- cd "$pkgname-v-${pkgver}"
+ cd "$pkgname-${pkgver}"
make DESTDIR="${pkgdir}" prefix=/usr install
install -dm 755 "${pkgdir}"/usr/share/licenses/autorevision